0

WIfi dongle TP-Link TL-WN823N will be not automatically recognized on RPI4B. I also can't find any matching drivers to install it manually.

How can I fix it to get it running?

Please help, I am a newbie.

Thanks and best regards

5
  • stop searching for RPi drivers and start searching for Linux drivers
    – jsotola
    Commented Feb 10, 2021 at 1:26
  • raspberrypi.org/forums/viewtopic.php?t=198015 - which version of that dongle do you have? what's the output of lsusb? Commented Feb 10, 2021 at 7:44
  • dongle is listed on lsusb but no wlan1
    – Damian
    Commented Feb 10, 2021 at 11:43
  • I already tried the mentioned manual from rotum entry mentioned in your comment but now it is listed on lsusb but still no wlan1 aviailable. Only on-board wlan0 pi@raspberrypi:~ $ lsusb Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 001 Device 005: ID 2357:0109 TP-Link TL WN823N RTL8192EU Bus 001 Device 004: ID 03f0:2b4a HP, Inc Business Slim Keyboard Bus 001 Device 003: ID 03f0:094a HP, Inc Optical Mouse [672662-001] Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    – Damian
    Commented Feb 10, 2021 at 11:49
  • pi@raspberrypi:~ $ rfkill list 0: phy0: Wireless LAN Soft blocked: no Hard blocked: no 1: hci0: Bluetooth Soft blocked: no Hard blocked: no
    – Damian
    Commented Feb 10, 2021 at 11:50

1 Answer 1

0

First link in a Google search it suggested top of the list after pasting the model of dongle into the search box lead to this on Ask Ubuntu. The detailed instructions are there for Debian too. Who knows if the source builds on arm.

https://www.google.com/search?client=firefox-b-d&q=tp-link+tl-wn823n+ubuntu

https://askubuntu.com/questions/1211157/how-do-i-get-a-tp-link-tl-wn823n-v3-wireless-adapter-working

4
  • Why are you posting links about ubuntu? Raspbian has nothing to do with Ubuntu Commented Feb 10, 2021 at 7:45
  • It is a procedure designed for any operating system, including Debian, which the Pi OS is based on. A driver needing compiled is the same procedure on all those operating systems. That is why it is posted it does the job he needs to get it done and working. Which you would know if you had read the material provided.
    – user130167
    Commented Feb 10, 2021 at 8:14
  • erm, sure, but why did you link to a page that uses D-link drivers for a tp-link, and the drivers come from a github that claims to be a mirror of something with no knowledge of what the code does :p sorry, but raspberrypi.org/forums/viewtopic.php?t=198015 is more trustworthy in my opinion :p Commented Feb 10, 2021 at 8:28
  • From the page in the section for building it. " If you have internet access by any other means (wired or through USB tethering), you can installed the RTL8192EU drivers for your TP-LINK TL-WN823N wireless adapter from Mange's GitHub repo. Here are the steps as described on the GitHub page:"
    – user130167
    Commented Feb 10, 2021 at 15:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.