0

i'd like to type in japanese on my pi 400, but i can't seem to get it to work. i do have japanese fonts; if i load a japanese website or text file, they display properly, but i can't seem to type in japanese characters. things i have tried:

adding the Keyboard Layout Handler to my panel, right clicking on it, changing settings to include both US and JP keyboard layouts. the alt+shift keyboard toggle does change the flag icon to the next language, but when i actually type, i don't get any japanese characters, but regular old english letters. i've also noticed that when i hit the "close" button, the dialogue box doesn't actually close, so i don't know if that's related.

the Keyboard Layout Handler settings dialogue box

i've also tried doing what i think is the same thing, just via the terminal, putting in

sudo nano /home/pi/.config/lxpanel/LXDE-pi/panels/panel

and then adding this to the end of the file:

Plugin {
  type=xkb
  Config {
    Model=pc105
    LayoutsList=us,ru
    VariantsList=,
    ToggleOpt=grp:alt_shift_toggle
    KeepSysLayouts=0
    DisplayType=0
  }
}

this produced the same result, i could change the flag, but couldn't actually type in japanese characters.

i also tried installing ibus/anthy via the add/remove programs interface, and i did get the box on the panel that let me switch between english and japanese, but again, when i tried to actually type, i didn't get any japanese characters, only english letters.

i did sudo update and full-grade my system this morning, and the japanese input still doesn't work. i don't know if i'm missing something obvious, but i figured i'd ask. thanks much~

0

I got this from a Japanese-language website. It uses mozc and ibus.

Type

sudo apt update

Then

sudo apt install ibus-mozc

Then reboot.

You’ll see a keyboard symbol in the upper right part of the taskbar. Right click on it. Click preferences. Click the input methods tab. Add Japanese-Mozc.

Now, you should see EN where the keyboard icon was.

Left click on it, and you can choose between English and Japanese input.

The default for Japanese is “direct input”, which isn’t what you want, probably. It’s indicated by a capital “A”.

Left click on the “A”, and you can choose what you want to type.

If you choose the Japanese “あ” you can input hiragana and kanji.

If you right click on the taskbar icon again and go to preferences you can set a new keyboard shortcut for switching between input methods.

I made mine [shift] [space].

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.