3

I just got a Raspberry pi 4 with 8GB and a SD. I ran all the updates and went directly to install docker and discovered that many images were randomly failing. I narrowed it down to the alpine:latest image and the date function going bananas

pi@raspberrypi:~ $ uname -a
Linux raspberrypi 5.4.83-v7l+ #1379 SMP Mon Dec 14 13:11:54 GMT 2020 armv7l GNU/Linux

pi@raspberrypi:~ $ docker run --rm alpine:3.12 ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=111 time=31.132 ms
64 bytes from 8.8.8.8: seq=1 ttl=110 time=112.076 ms
^C
--- 8.8.8.8 ping statistics ---
3 packets transmitted, 2 packets received, 33% packet loss
round-trip min/avg/max = 31.132/71.604/112.076 ms
pi@raspberrypi:~ $ docker run --rm alpine:latest ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
ping: clock_gettime(MONOTONIC) failed

It looks that it works with 3.12 but not in latest.

Any ideas? I just bought the raspi so maybe I didn't set up docker well?

pi@raspberrypi:/usr/bin $ docker run --rm alpine:latest date
Sun Jan  0 00:100:4174038  1900
pi@raspberrypi:/usr/bin $ docker run --rm alpine:3.12 date
Sun Feb  7 20:33:53 UTC 2021

Looks like date fails so everything else (naturally) fails.

More info

pi@raspberrypi:/etc/apt/sources.list.d $ cat docker.list
deb [arch=armhf] https://download.docker.com/linux/raspbian buster stable
pi@raspberrypi:/etc/apt/sources.list.d $ lsb_release -cs
buster

I already tried to uninstall and reinstall docker without luck. Any ideas? Many images keep failing which renders the raspi kinda useless for my use case since I wanted to do everything with containers.

1
  • Same here. I have raspberry pi 4 4GB - Linux raspberrypi 5.10.11-v7l+ #1399 SMP Thu Jan 28 12:09:48 GMT 2021 armv7l GNU/Linux alpine:3.12 works fine, but on alpine:3.13 I get: Sun Jan 0 00:100:4174038 1900 – Mateusz Feb 12 at 17:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.