3

I have working with Raspberry Pi for the last month. I tried to downloaded the OpenCV library today and I noticed that the SD card is only using 2GB out of 8GB so stupidly, I tried to reformat my SD and downloaded the OS again, but now my RPi can't read anything.

Any tips on what has gone wrong?

3

It seems like you have messed up your SD card partitions or image. To correct this, reimage the card (instructions here). Then on first boot you will be presented an options screen. One of the options is to resize the root partition (more info on the raspi-config file and its options). That will format the card's root partition to utilize the full 8GB of your card. Note this will require a reboot.

0

Make sure your power supply providing sufficient power to raspberry pi device. The range of power supply should between 4.75 and 5.25 volts. You check your power problem on Rpi Hardware. If the power is adequate than it may problem with your partitioning. You should format SD Card at 32fat. If you are using Linux than follow the instruction for partitioning Oracle Java (Heading:Resize the SD Card Partitions).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.