1

I have my route at AC channel 120 with 160MHz bandwidth.

However, RPi 4 is always locked to 54.0 Mbit/s ?

It's located right next to the router and the practical speed is about 7Mbyte/s.

Is this intentional or hardware limits ?

enter image description here

enter image description here

enter image description here

wlan0     IEEE 802.11  ESSID:"OpenWrt_nac"  
          Mode:Managed  Frequency:5.18 GHz  Access Point: XXXX   
          Bit Rate=433.3 Mb/s   Tx-Power=31 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=70/70  Signal level=-35 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Update: Switched to 160MHz, still 54Mbps.

Update: It's because of the cheap SOC hardware.

5
  • how are you testing the speed? Commented Feb 14, 2021 at 2:25
  • 1
    the rpi most likely connect to the wifi n AP. Try to make 2 separate APs, one for 2.4GHz and one for 5GHz, and then force your rpi to connect on the 5GHz.
    – solsTiCe
    Commented Feb 14, 2021 at 11:34
  • @JaromandaX WinSCP
    – 7E10FC9A
    Commented Feb 14, 2021 at 14:16
  • @solsTiCe It's AC only AP (channel 35), the name is nac because it could support N.
    – 7E10FC9A
    Commented Feb 14, 2021 at 14:17
  • what's the output of iwconfig on the pi? Commented Feb 14, 2021 at 21:19

1 Answer 1

2

I'm by no means an expert in this, but it looks like you're trying to use the channel 42 (5170-5250 MHz), which appears to be disabled on the Pi 4. You claim to use channel 35, but I see no such channel on Wikipedia.

If fact, only 20MHz channels are actually listed as available on the Pi 4, and some HT40/HT80 channels are explicitly disabled. Perhaps the Pi falls back from an unusable channel to plain 802.11a, which is limited to 54Mbps:

    Band 2:
            Capabilities: 0x1062
                    HT20/HT40
                    Static SM Power Save
                    RX HT20 SGI
                    RX HT40 SGI
                    No RX STBC
                    Max AMSDU length: 3839 bytes
                    DSSS/CCK HT40
            Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
            Minimum RX AMPDU time spacing: 16 usec (0x07)
            HT TX/RX MCS rate indexes supported: 0-7
            VHT Capabilities (0x00001020):
                    Max MPDU length: 3895
                    Supported Channel Width: neither 160 nor 80+80
                    short GI (80 MHz)
                    SU Beamformee
            VHT RX MCS set:
                    1 streams: MCS 0-9
                    2 streams: not supported
                    3 streams: not supported
                    4 streams: not supported
                    5 streams: not supported
                    6 streams: not supported
                    7 streams: not supported
                    8 streams: not supported
            VHT RX highest supported: 0 Mbps
            VHT TX MCS set:
                    1 streams: MCS 0-9
                    2 streams: not supported
                    3 streams: not supported
                    4 streams: not supported
                    5 streams: not supported
                    6 streams: not supported
                    7 streams: not supported
                    8 streams: not supported
            VHT TX highest supported: 0 Mbps
            Bitrates (non-HT):
                    * 6.0 Mbps
                    * 9.0 Mbps
                    * 12.0 Mbps
                    * 18.0 Mbps
                    * 24.0 Mbps
                    * 36.0 Mbps
                    * 48.0 Mbps
                    * 54.0 Mbps
            Frequencies:
                    * 5170 MHz [34] (disabled)
                    * 5180 MHz [36] (20.0 dBm)
                    * 5190 MHz [38] (disabled)
                    * 5200 MHz [40] (20.0 dBm)
                    * 5210 MHz [42] (disabled)
                    * 5220 MHz [44] (20.0 dBm)
                    * 5230 MHz [46] (disabled)
                    * 5240 MHz [48] (20.0 dBm)
                    * 5260 MHz [52] (20.0 dBm) (no IR, radar detection)
                    * 5280 MHz [56] (20.0 dBm) (no IR, radar detection)
                    * 5300 MHz [60] (20.0 dBm) (no IR, radar detection)
                    * 5320 MHz [64] (20.0 dBm) (no IR, radar detection)
                    * 5500 MHz [100] (20.0 dBm) (no IR, radar detection)
                    * 5520 MHz [104] (20.0 dBm) (no IR, radar detection)
                    * 5540 MHz [108] (20.0 dBm) (no IR, radar detection)
                    * 5560 MHz [112] (20.0 dBm) (no IR, radar detection)
                    * 5580 MHz [116] (20.0 dBm) (no IR, radar detection)
                    * 5600 MHz [120] (20.0 dBm) (no IR, radar detection)
                    * 5620 MHz [124] (20.0 dBm) (no IR, radar detection)
                    * 5640 MHz [128] (20.0 dBm) (no IR, radar detection)
                    * 5660 MHz [132] (20.0 dBm) (no IR, radar detection)
                    * 5680 MHz [136] (20.0 dBm) (no IR, radar detection)
                    * 5700 MHz [140] (20.0 dBm) (no IR, radar detection)
                    * 5720 MHz [144] (disabled)
                    * 5745 MHz [149] (disabled)
                    * 5765 MHz [153] (disabled)
                    * 5785 MHz [157] (disabled)
                    * 5805 MHz [161] (disabled)
                    * 5825 MHz [165] (disabled)

Try setting up a 20MHz channel on your router, e.g. channel 36, or, with a smaller chance of success, a 40MHz/80MHz channel which is at least not explicitly disabled, e.g. channel 54 (40MHz) or 58 (80MHz). Note that you will still be limited by the Pi4 hardware which supports a single data stream with MSC7, which means the data rates will be capped at 72Mbps with a 20 MHz channel, 150 Mbps with a 40 MHz channel and 325 Mbps on a 80 MHz channel.

3
  • Sorry for the typo, it's ch 36. Are you sure ch36 is 20MHz only ? because according to my router it's running at 80MHz.
    – 7E10FC9A
    Commented Feb 16, 2021 at 19:50
  • Your router either lies about the center frequency (5180 MHz), and by extension the channel number, or about the bandwidth (80 MHz). From experience I believe it's the former: the router just calls the channel by the name corresponding to the first 20MHz channel covered by the 80 MHz band, and that's channel 36. In that case, pick channel 52 if you want channel 58 :) Commented Feb 17, 2021 at 14:24
  • If only 20 MHz channels are available, which seems to be the case for me at least when trying to start hostapd to create an access point, then how does this test reach practical speeds of 11 MB/s?: notenoughtech.com/raspberry-pi/… — are speeds lower when creating an AP?
    – Andreas
    Commented Nov 13, 2021 at 4:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.