2

I know this is a old topic but even after reading dozens of comments i couldn't solve the problem. With hdmi plugged to raspberry everything is fine. When I don't plug HDMI my resolutioin is too big(in scale automatically vnc option) and small in scale to 100%. I've tried to modify parameters in config.txt but nothing. Maybe there is a conflict between config.txt and something else? I don't know I am a bit ignorant with this.

I try to post my config.txt. my uncommented rows:

*--uncomment to force a console size. By default it will be display's size minus
-- overscan.

framebuffer_width=1920

framebuffer_height=1080

--uncomment if hdmi display is not detected and composite is being output

hdmi_force_hotplug=1

--uncomment to force a specific HDMI mode (this will force VGA)

#hdmi_foce_mode = 1

#hdmi_group=2

#hdmi_mode=82

dtoverlay=gpio-fan,gpiopin=14,temp=90000*

I also tried to uncomment hdmi parameters. but nothing. What could I do?

Thank you everyone. It's been all day i'm trying to solve this problem

2 Answers 2

2

I had a similar issue with my raspberry and VNC Viewer. I managed to solve it by setting up the headless resolution to the resolution of my screen (the one I use to connect remotely, which is 1920x1080). Open the main menu (top left)>Preferences>Raspberry Pi Configuration>Display and set your resolution.

It is easier to do it this way with a screen than doing it with raspi-config.

1
  • This option is completely ignored for me and the Screen Layout Editor only shows 640x480 as the only option.
    – ScrappyDev
    Oct 24, 2023 at 1:33
1

Don't fiddle with framebuffer (which is pointless on a Pi4)

Set the default resolution (preferably while a monitor IS connected) in raspi-config. Then you will have the same resolution whether a monitor is connected or not.

See https://raspberrypi.stackexchange.com/a/113873/8697

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.