2

I'm trying to follow Wireless Setup - ArchWiki to set up my WiFi, yet running into some issues:

[root@alarmpi ~]# dmesg | grep -i rtl8192cu
[    7.697779] usbcore: registered new interface driver rtl8192cu
[root@alarmpi ~]# lsmod | grep 8192cu
8192cu                487313  0 
[root@alarmpi ~]# iw dev wlan0 scan
nl80211 not found.
[root@alarmpi ~]# 

Please advise.

  • Note that the RTL8192CU kernel driver is loaded automatically in the latest Raspian distribution. – syb0rg Dec 6 '13 at 4:47
  • @syb0rg you should've left your instruction) I wanted to try them out if I wouldn't find any other solution. I'm on Arch Linux not Raspian though( – alexus Dec 6 '13 at 5:09
  • It looks like you are not alone in your issue. I removed my answer because I did not think that it would solve the issue (based on past experiences of my own). Here is the link if you still want to try it out (instructions are in the readme). – syb0rg Dec 6 '13 at 5:18
  • How about the listing for the actual device in lsusb -v? You should say what it is. – goldilocks Dec 6 '13 at 13:13
  • @goldilocks output from lsusb -v is at pastebin.com/U8aY0NMc – alexus Dec 7 '13 at 1:05
1

It is possible to get the Realtek RTL8188CUS (EdiMax EW-7811Un) device to work properly under Arch Linux by using a later kernel. It seems according to this discussion that it's been working since kernel-3.13, but the default kernel that is currently installed by Arch Linux is version 3.12.26 (as of 5sept14). So to install a newer kernel you need to install the linux-raspberrypi-latest package (currently 3.16.1):

pacman -S linux-raspberrypi-latest

Then reboot and you should have a system that talks to the Wifi using nl80211 and hence commands such as iw and hostapd will now work properly.

EDIT[14feb15]: Unfortunately the 'linux-raspberrypi-latest' package appears to have been discontinued. The latest Arch kernel now uses the Realtek driver (v4.0.2_9000.20130911), as opposed to the upstream-linux (rtlwifi) driver, which is more stable for normal use but does not provide for monitor mode. If you want to use the monitor mode driver you'll have to build the (rtlwifi) kernel module. Buliding the module isn't too hard - it's simplest to cross-compile the whole kernel on another Linux box. To enable the rtlwifi drivers you'll need to uncomment them from the raspberrypi kernel wireless config (Kconfig and Makefile) then enable rtlwifi when you run make menuconfig.

0

Using wext driver & iwconfig works for me, see: https://wiki.archlinux.org/index.php/WPA_supplicant#Specifying_driver

  • Welcome to Raspberry Pi! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. If you could include the important info from the link it would make your answer more useful and help keep this site/Q:A more useful in the future, as including this info protects against link rot. – RPiAwesomeness Mar 9 '14 at 20:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.