0

I corrupted the ssd, so until I get this error again (hopefully I won't, but I probably will because it already happened 2 times) I can't do anything.

I got a messagebox with this error when booting:

org.freedesktop.DBus.Error.Spawn.ExecFailed: Failed to execute program org.blueman.Mechanism: permission denied

this is on a new and fresh system.
here is what I tried so far after some googling:

sudo chmod 4754 /usr/lib/dbus-1.0/dbus-daemon-launch-helper
sudo chown root:messagebus /usr/lib/dbus-1.0/dbus-daemon-launch-helper

I connected to the internet with USB tethering from my phone and tried this:

sudo apt-get install --reinstall dbus

I rebooted and wifi still doesn't work, though after the first 2 commands the ethernet port showed up and USB tethering works (but I don't know if they didn't work before, I'm assuming they didn't because the ethernet port didn't show up in the network panel applet). also worth mentioning is that I had a sudo error before this happened (fixed by loging in to tty1 as root and running chown root:root /etc/lib/sudo/sudoers.so).

I have no idea what to do, but I really need wifi working again, many thanks in advance!

2
  • I accidentally corrupted the ssd trying to back it up. I'll update the question I get this error again. Feb 17 at 10:18
  • 1
    You're fiddling with rights and ownership on important system files too carelessly. That usually only makes the situation worse.
    – Ingo
    Feb 22 at 10:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.