-1

What am I running:

Raspberry Pi OS Lite v5.4 - Linux raspberrypi 5.4.83-v7l+ - on a Raspberry Pi 4B

When I tried to add a systemd service, and run into the error (happens with any systemctl command):

System has not been booted with systemd as init system (PID 1). Can't operate.
Failed to connect to bus: Host is down

As far as I understand systemd should be used as default when booting. I followed the instructions here and ran sudo stat /proc/1/exe I see that it is not systemd (which I suppose should point to /bin/systemd):

  File: /proc/1/exe -> /usr/sbin/init
  Size: 0           Blocks: 0          IO Block: 1024   symbolic link

I initially did not change anything in the boot configuration - is this expected behaviour?

Since I wanted to change it to boot with systemd I tried to add the init parameter to the kernel parameters in /boot/cmdline.txt. I added it like this:

console=serial0,115200 console=tty1 root=PARTUUID=10ded32f-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait init=/bin/systemd

But when I do this the raspberry fails to start.

Any ideas how I could change it to use systemd?

0

I had another deeper look into the debian documentation and did the following steps to fix it:

Installed systemd-sysv as per the documentation section "Configure as default" : apt-get install systemd-sysv

This alone did not fix the issue (but I am not sure if it helped so I am stating it) - this did fix the issue:

Add init=/lib/systemd/systemd as kernel parameter (prepended) to /boot/cmdline.txt which then looked like this:

init=/lib/systemd/systemd console=serial0,115200 console=tty1 root=PARTUUID=10ded32f-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait

Still baffled that it was not activated by default, if anybody knows more I am happy about an explanation.

2
  • 1
    The only that can be said is, that a fresh flashed and unmodified Raspberry Pi OS image will boot with systemd as PID 1 out of the box. Either you don't flashed an image from the official download site or there has something gone wrong with the flashing. You should verify the SHA256 file integrity hash on the downloaded zip archive. – Ingo Feb 18 at 13:25
  • I used Raspberry Pi Imager v1.5 to flash. "Raspberry Pi Os Other" > "Raspberry Pi OS Lite (32-Bit)" was selected. Release 2021-01-11 (which corresponds to what I texted above). I am not sure what "could go wrong" but if I am the only one running into this problem I suppose something did go wrong. – dakami Feb 19 at 2:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.