0

I have bought an ePaper display and an BME280 sensor. The ePaper display itself is successfully powered via SPI (https://www.waveshare.com/wiki/4.2inch_e-Paper_Module_(B)) and the BME280 should be powered via I2C.

The problem here is that the BME280 sensor (I already tried several) is not detected via I2C.

Sensor is connected as follows:

VIN: Pin 1 (3,3)
GND: Pin 9 (GND)
SCL: Pin 5 (GPIO 3)
SDA: Pin 3 (GPIO 2)

I2C is enabled in the raspberry pi 4.

Under /etc/modules it is listed:

i2c-dev
i2c-bcm2835

ls /dev/i2c* lists me:

/dev/i2c-1

lsmod | grep i2c lists me:

i2c_bcm2835            16384  0
i2c_dev                20480  0

And finally the output of sudo i2cdetect -y 1:

     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- --
10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --

As far as I know there is nothing else to do for reading this sensor. So what could be my problem here? Could it be that the Pi could not power both devices? A point against could be that the display itself is not running at the moment (no script for it runs).

I am using a raspberry pi 4 with current raspbian buster lite.

Here is how I have it put together:

Image 1 Image 2

For Better resolution: (https://ibb.co/7jby0Hs)! (https://ibb.co/zVqD75M)!

12
  • Is this BME280 one that comes on a breakout board or just the plain chip?
    – PMF
    Feb 19 at 7:56
  • I have these: amazon.de/… Feb 19 at 7:58
  • I'd forgot to say that the raspi cam v1 is attached to the pi too Feb 19 at 7:59
  • Hmm... there's not much you can mess up with this chip. Some chips that have both SPI and I2c support sometimes act out if the unused pins are floating, but this one does not have any extra connections.
    – PMF
    Feb 19 at 8:03
  • 2
    We need a clear photo showing the connections between Pi and module.
    – joan
    Feb 19 at 8:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.