0

I've been trying to run an install script on my raspberry pi 4, and I keep getting the same error. The script is meant to install a soundcard for a multiple microphone adaptor on the pi, I've got it to work many times before but today I did a fresh install and tried again and it's not working.

I'm following the instructions given at the respeaker seeed website, as follows:

sudo apt-get update
sudo apt-get upgrade
git clone https://github.com/respeaker/seeed-voicecard.git
cd seeed-voicecard
sudo ./install.sh 

and I run into problems when it comes to installing the sound card driver:

Creating symlink /var/lib/dkms/seeed-voicecard/0.3/source ->
/usr/src/seeed-voicecard-0.3

DKMS: add completed.

Kernel preparation unnecessary for this kernel. Skipping...

Building module: 
cleaning build area..
make -j4 KERNELRELEASE=5.10.11-v71+ -C /lib/modules/5.10.11-v71+/build M=/var/lib/dkms/seeed-voicecard/0.3/build....(bad exit status: 2)
Error! Bad return status for module build on kernel: 5.10.11-v71+ (armv71)
Consult /var/lib/dkms/seeed-voicecard/0.3/build/make.log for more information.
Can't compile with this kernel, aborting 
Please try to compile with the option --compact-kernel 

I feel like I'm reading another language looking at it so any other help for what to do next would be incredibly useful.

I had a look at the make.log but its super long and I don't know how to find what would be useful in it. Please let me know if there's anything I can do to get this fixed!

Thankyou!

1
  • "I had a look at the make.log but its super long..." Try tail -n 75 /var/lib/dkms/seeed-voicecard/0.3/build/make.log and edit that in (it's the last 75 lines, unrecoverable failures tend to be one of the last things to happen). Did you "try to compile with the option --compact-kernel"? Does that make any difference? Also, edit in the output of ls /lib/modules/5.10.11-v71+/build | wc -l (it will either be a number or an error). – goldilocks Feb 19 at 15:03
1

Use sudo ./install.sh --compact-kernel for the install command, like the error suggests you do. An sudo apt install build-essential may be an idea to ensure you have all the pieces installed and checking that the kernel-headers-5.10.11-v71+ however it is named for your running kernel is installed or it will never build.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.