1

This is a fun one: somehow, the screen reader accessibility setting has been turned on in my Raspberry Pi OS environment. I can't figure out how to turn it off! Other than turning off all audio, the only solution I've found is to uninstall the eSpeak module and supporting libraries, which is obviously not the ideal solution.

I've tried googling around but found only tutorials on how to install the text-to-speech.

Anyone know how this gets turned on and how one turns it off?

2
  • 2
    sudo apt purge orca – Dougie Feb 21 at 1:12
  • Thanks. That just removes a package. (I don't think it's using Orca; I think it's using eSpeak.) Anyway, I'm hoping to actually turn off the setting so that I can keep the packages installed but not have the UI constantly reading to me. – jbeldock Feb 21 at 21:38
3

espeak is a speech synthesizer, it transforms text into sound but will not grab text from your screen and read it aloud. This is a function of screen reader. You have to find out which one you have and uninstall or disable it.

In case you got orca for a screen reader, it can be deactivated by removing /etc/xdg/autostart/orca-autostart.desktop.

1
  • 1
    In the file /etc/xdg/autostart/orca-autostart.desktop I commented out the line Exec=orca, now it looks like this #Exec=orca. It worked, the annunciation stopped after reboot of Raspbian buster, Release 10 system. – AjayKumarBasuthkar Apr 8 at 8:12
0

You might try to kill a specific process/es as described here. Please try and check if that helps. I checked my Raspberry Pi OS and orca is not installed by default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.