0

I've been using the Respeaker 6 Mic array and Seeed-Soundcard for months and was just about to start a field deployment with them however I reflashed my SD cards and tried to reinstall the soundcard but it will no longer work rendering the device unusable.

The install from the website is as follows, which I followed as usual:

sudo apt-get update
sudo apt-get upgrade
git clone https://github.com/respeaker/seeed-voicecard.git
cd seeed-voicecard
sudo ./install.sh 

This time the install didn't work first time and I had to use sudo ./install.sh --compat-kernel instead which appeared to run the install fine.

After reboot, where ordinarily I'd be able to see (using arecord -L) and use the soundcard, the soundcard wasn't there and my microphone array could not be detected.

August 2020 respeaker said they were planning to fix the issue but it's now January and they've not said anything since. I suspect they've got a lot on and the sound card isn't being maintained as I haven't found a solution on their forums. One person forked the soundcard repo and fixed the issue but this also doesn't work with the more recent releases.

At this point, I really don't know what to do. Can I roll back the Raspbian OS? How can I do that? Is that a bad idea? Would that be reversed when I run an update or an upgrade?

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.