0

I can't connect to the internet on the pi itself and I cannot connect to the internet through the pi.

But the pi shows up on my phone when I search for access points, I can even connect to it with the password, but the internet won't work.

When I click on the two blue arrows pointing up and down in the top right it says "no wireless interfaces found." when I hover over it with my mouse it says:

"eth0: Link is down

wlan0: Associated with

wlan0: Configured 192.168.4.1/24"

I used this tutorial https://www.raspberrypi.org/documentation/configuration/wireless/access-point-routed.md

I found a similar question with no answer here I'm successfully running a Raspberry Pi 3 Model B as a WiFi access point, but I cannot connect to the internet through the Pi itself?

some comments said to post command outputs, so here is a link to the three commands they asked for https://imgur.com/gallery/WwMnY8v

Any tips?

Thank you

9
  • I gather internet access should be via eth0, and since eth0: Link is down, there's your issue - do you have a cable connecting it? Feb 23 at 4:39
  • Please execute the following commands on the command line and add its output to your question: ip addr and ip route.
    – Ingo
    Feb 23 at 9:14
  • @Ingo I have those commands in the imgur image Feb 23 at 17:24
  • @JaromandaX does it have to be connected through ethernet? Feb 23 at 17:26
  • @JaromandaX I plugged in ethernet and it changed to eth0: configured 169.254.85.66/16, but I still can't connect Feb 23 at 17:42
2

To have a decent answer here is the solution the questioner stated in a comment:

I found the problem, I plugged it into the wrong ethernet port. there was a light on the pi to turned on so I thought it was correct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.