1

I am following this page for instructions: https://www.raspberrypi.org/documentation/pico/getting-started/

I see the pico added as a drive when I hold sel button, and apply power with the usb cable.

When I drag the micro python file to the drive, it starts to copy, but then I see this message:

Drive was removed without ejecting

I also have seen the message on my screen that power is low. I thought that changing to a 3 amp power supply might help, but I still get the same message.

I have had the RPi 2 for several years, and never had any problems with power.

What can I do to load Micro Python to the Pico, and begin exploring

1
  • Udate, using the terminal i was able to copy the file to the Pico. Maybe something about the File Manager was causing my problem. I would still be interested if anyone knows more about this? Feb 23 at 15:41
2

I have a similar issue with this. I use a Rpi 3b+ with no issues as well as a windows 10 machine and a Linux Mint machine, all of which have worked. The only time that I have had an issue is when I load a custom main.py file then try and reflash the pico. The cause of this issue is due to the fact that in order to flash the rom of the chip, it must power down. This will cause that alert, don't worry no damage was done. The pico unlike other devices was designed for sudden power loss without damage. Firmware is stored on ROM and code, unless precompiled is stored in persistent and volatile ram respectively of it use and scope.

Anyways, I use Thonny to test with as well as using it to flash the firmware, due to the fact that it usually gets the latest port of Python. The best practice is to clear the firmware then reflash it. Using the flash_nuke.uf2 file from RaspberryPi.org will clear it, then flash with Thonny and you should be good to go. Comment if you have any questions.

5
  • 1
    You have some good details, but I think I am missing something. I'm not a pico or microPython user at present, so could you make it clear if and how you can install microPython on an RPi 0, 1, 2, 3, 4 ? I assume it's the same process??
    – Seamus
    Feb 24 at 19:44
  • 1
    @Seamus, it depends on what you mean by install. The Raspberry Pi Pico works off of the RP2040 chip which is a microcontroller similar to the ESP32 and ESP8266. The Raspberry Pi zero,1 2, etc are SBCs or Single Board Computers that run on an ARM CPU (Central Processing Unit). MCs are not capable of running OS and use firmware stored in flash memory(ROM) to operate. Where an OS is similar to firmware but much more robust. rptl.io/pico-micropython <- This will download a pdf that will guide you for setting up the IDE and SDK to write code, but you will need a MC to compile / Interpret it Feb 25 at 20:42
  • 1
    Cont'd. But yes it is the same process on all SBC's from Raspberry Pi. I have several models and would not recommend the Zero since it has limited RAM and can be very laggy. If you have a 3b+ or newer you will be best off! I use windows 10 with Bonjour print service to connect and it works great. Feb 25 at 20:47
  • 1
    By "install" I mean all the usual things - first and foremost being I can run it, write code and debug code on RPi 1,2,3,4,0. If I must have a Pico to run the code then it has no use for me.
    – Seamus
    Feb 26 at 1:24
  • 1
    @Seamus, Yes, you must have a microcontroller to run micropython. it does not; however, need to be a pico. it can also be a pyboard, esp8266, esp32, etc. micropython.org/download shows all MC's that work with uPy. Mar 2 at 15:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.