1

I am using three DRV8833 motor drivers. The power supply is currently a usb cable with the ground and power connected to a breadboard with the three motor drivers attached to them. When powering all motor drivers at the same time only some of them actually move. Testing the drivers out one by one works fine. I assume it's because of the sudden drop of voltage in the circuit and wanted to ask if there is a way to solve this problem, e.g. with the use of diodes or resistors or a power supply that is able to maintain a consistent voltage (~2-3v) across a large number of devices that suddenly start draining power.

1
  • usb phone chargers and cable usually supplies max 500mA, but your motors might need more than that. Perhaps you can give us a web link to your motors so we can look at the motor specs to suggest more things.
    – tlfong01
    Feb 26 at 1:27
1

Perhaps a capacitor in the circuit to store and release the power once needed, a buffer for the load.

1

The best solution, while obvious, is to use a separate power supply for the motors, as the raspberry pi's power supply only supplies 2-3 amps.

0

When I did my raspberry pi pan and tilt webcam had the same issue in that on boot the servers caused over voltage on the board and it would reboot and repeat ad-infinitum.

However it was only at boot time if I disconnected one of the servos and then reconnected it after boot it was fine..

So I used a AXICOM D2N (Signal Relay) to allow me to disconnect the servos at boot and then connect them one by one once the power was up.

This method isn't as elegant as supplying independent power to the servos but it does work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.