1

On my RPi Zero W I had a kernel panic issue

Kernel panic-not syncing: VFS: unable to mount root fs on unknown-block(179,6)

but I managed to fix it with the help from the second aswer from this post: Kernel panic-not syncing: VFS: unable to mount root fs on unknown- block(179,6) running Raspbian on top of NOOBS

However now it halts while booting and the last line says

Started Update UTMP about System Runlevel Changes.

I checked the filesystem with fsck and it seems ok. What can I do to boot succesfully?

Edit: I should clarify that I don't have NOOBS installed, just Raspberry Pi OS

5
  • I fall to understand why anyone persists in trying to boot NOOBS. Install Raspberry Pi OS – Milliways Mar 2 at 10:46
  • @Milliways no NOOBS, I'll clarify it in the post – Matipolit Mar 2 at 10:48
  • If you are running Raspberry Pi OS you could not possibly get that error. – Milliways Mar 2 at 10:50
  • I used the official imaging tool from raspberrypi.org/software and installed Raspberry Pi OS Lite, is that NOOBS? – Matipolit Mar 2 at 11:18
  • @Milliways It better be possible because I'm getting the same error on a new SD card formatted using the Raspberry Pi Imager in a RPi 3+. It worked on second boot though. – thordarson May 3 at 16:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.