0

This is my first time working with any Raspberry Pi. I'm trying to set up my pi zero for pi hole. Following an online guide, I downloaded Raspberry Pi OS Lite and used Raspberry Pi Imager to image the OS onto the microSD card.

This is where things start to diverge from the guides. After reinserting the microSD, File Explorer shows "USB Drive (K:)" and no other devices/drives (except "Local Disk (C:)"). In most guides this apparently should show up as "boot (K:)", I think. The fact that it is K is most likely due to me mucking around in disk management and reassigning the drive letter during some earlier attempts at troubleshooting.

Using Disk Management, I can see the drive labelled as "boot (K:)", and it has 2 partitions (256MB and 1.48GB, with 27.08GB unallocated)

In any case, "USB Drive (K:)" clearly contains the OS; there are many files including config.txt, kernel.img, etc.

Here's my problem: When I go to create an empty file titled "ssh" or "ssh.txt", I get the error:

You can't save to 'K:'. Please choose another location.

I've tried with both VS Code and Notepad. What am I doing wrong?

5
  • how do you "go to create an empty file"? i.e. what do you do to create this empty file? Commented Mar 9, 2021 at 0:29
  • This is a problem with Windows - nothing to do with Pi.
    – Milliways
    Commented Mar 9, 2021 at 0:30
  • 1) Open notepad 2) File->Save as 3) "ssh" as file name and "All Files (.)" as "Save as type" 4) Click save, get same error. Same thing happens if I change the extension to .txt.
    – Will Sni
    Commented Mar 9, 2021 at 0:32
  • I would start with a fresh image and use Etcher. Make sure that the verify option is checked and when the image is done and Windows says it cannot read the disk IGNORE that. It's OK to create a file called 'ssh.txt' - the Pi start up program looks for this or a file called 'ssh'
    – user130616
    Commented Mar 9, 2021 at 1:04
  • @Milliways was right - this was a problem with my hardware. On my windows computer, using my USB sd card reader didn't work. On my macbook, plugging the sd card directly into the built-in sd card reader didn't work. But using the same USB sd card reader in a USB port on my macbook magically worked. I confirmed this with a second sd card I borrowed from a friend. Thank you commenters for your help.
    – Will Sni
    Commented Mar 9, 2021 at 3:34

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.