I am using a Raspberry Pi 3 B+ with nthe latest version of Raspbian (version 9). I have recently purchased the Adafruit Ultimate GPS Breakout for a project that assists Blind users around their environment using this GPS module. To use my GPS module, I need to install Circuit-Python along with Blinka libraries to assist the module. I keep getting an error message when I run the following code in the terminal:

$ sudo pip3 install adafruit-circuitpython=gps

The error pertains to having the incorrect version of Python installed. Originally my main verse ion of Python was version 3.5, and Circuit Python requires 3.6 and above. So I installed version 3.8 to my Pi. The problem now is that I still get the error message. I think it has something to do with having multiple versions of Python on my Pi(2.7,3.5, and 3.8). What should I do to make 3.8 my main Python version?

Note when I type:

$ python --version

into the terminal it says Python 3.8.0

  • Just install the current Raspberry Pi OS. Yours is 2 years old.
    – Milliways
    Mar 18, 2021 at 21:27
  • How do I go about doing that? I've seen something on this tutorial I am following that mentions OS buster. If I get the current RPi OS will it have Python 3.6 or higher? Mar 18, 2021 at 21:31
  • Current python3 is 3.7
    – Milliways
    Mar 18, 2021 at 21:40
  • Incidentally if your python -V says 3.8 you have done something wrong. This should be 2.7
    – Milliways
    Mar 18, 2021 at 21:44
  • Well I recently installed Python 3.8, before I did this the version was Python 3.5. I have 2.7 as well. Mar 18, 2021 at 21:45

1 Answer 1


Just a few things to try:

  1. What do you get if you type python3 --version? I'm thinking it's possible python3/pip3 is mapped to python 3.5 and python/pip is mapped to 3.8.
  2. Since we know the version of typing python is 3.8, you could just use pip which should use the same version.
  3. When you un the script, are you using sudo? If not, the module should be installed without the sudo command.
  4. I'm not sure if you typed it with the = sign or if that was just a typo on stack exchange, but it should be sudo pip3 install adafruit-circuitpython-gps.
  5. You could try using python -m pip in place of pip3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.