1

I'm trying to set up a Kubernetes cluster on a bunch of Raspberry Pi 4B nodes. I adopted the setup I use for my v-kube-cluster (Kubernetes in virtual boxed using vagrant). See https://github.com/sebastian9486/v-kube-cluster (but not essential to my question).

Setting up the Kubernetes cluster on the RasPi nodes seems to work until I try to initialize the cluster using kubeadm init --node-name k8s-master. Somehow the RAM of my RasPi is not recognized. The machine has 8GB of RAM, but I always get below error message.

[ERROR Mem]: the system RAM (1 MB) is less than the minimum 1700 MB", "\t[ERROR SystemVerification]: missing required cgroups: memory"

The OS of each RasPi is "Raspbian GNU/Linux 10 (buster)" and the kernel is " Linux k8s-master 5.4.83-v7l+ #1379 SMP Mon Dec 14 13:11:54 GMT 2020 armv7l GNU/Linux" (with k8s-master being the node name).

Anyone got an idea how I can fix the issue with RAM detection? Does ubuntu as OS for the RasPi nodes work better?

1

A quick googling reveals vagrant has configuration options for RAM and CPU count which should be made available to a VM:

config.vm.provider "virtualbox" do |v|
  v.memory = 1024
  v.cpus = 2
end
1
  • the v-kube-cluster link was only for information ... my problem actually is with my raspi hardware. I adjusted my v-kube-cluster slightly to install kubernetes on raspi. which seems to work until said memory detection problem. – Sebastian Sommerfeld Mar 25 at 13:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.