0

I have a question regarding RealVNC and the Raspberry Pi 3B. I can't connect to the Raspberry pi and I get following error message: "Timeout while waiting for a response from the computer". A VNC connection worked fine a few months ago, but now I somehow just can't connect to the RPi.

What I have tried so far:

  • Reboot of Computer (Client) and RPi (Server)
  • Reinstalled RealVNC software on both Computer and RPi
  • Checked open ports of RPi: Works fine, 5900 is open
  • Tried VNC Connect on other device (smartphone), but same error message

Everything I checked is working fine, but I still get the error message. And as I said, it worked really good a few months ago and I haven't changed anything regarding the VNC server.

I would be very happy if someone knew a solution for my problem. Thanks already!

3
  • Are the two computers (client and pi) in the same network? Does ping work? – PMF Mar 23 at 13:13
  • I just found the problem. Ufw was active and didn't allow port 5900. Should I delete the question? The only thing I don't understand is why it worked a few months ago, because I used ufw and still could connect. But now it's working again as I added the rule. – JacobSelt Mar 23 at 13:18
  • You can add this as an answer. Maybe someone else will have a similar issue. – PMF Mar 23 at 13:24
1

Be aware of a few things that could impact this:

Do not open your router firewall to allow VNC from the Internet. It is better for LAN security to create a free account (non-commercial use only) and sign in over the web connect feature provided by RealVNC free of charge.

UFW should restrict the port access to a specific network (your local LAN) or even better a given IP address.

Port 5900 is the default, it can be changed at the Pi end.

A second display uses port 5901, the third 5902 etc

0

I could not connect because ufw was active and there was no rule for port 5900. So I created a rule and now it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.