I have a new Raspberry Pi Zero W and I downloaded the latest Raspbian Buster Lite installing it on a brand new 32 GB microSD card using Rufus. I created a wpa_supplicant.conf file so that it would automatically have my Wi-Fi information on startup and connected to HDMI and a USB keyboard. I made sure internet was working by pinging google: ping google.com. The first two commands I am trying to run are sudo apt-get update and sudo apt-get upgrade. The update seems to be working, but the upgrade is having issues connecting with errors like:

Err:53 http://archive.raspberrypi.org/debian buster/main armhf rpi-eeprom armhf 11.12-1

Unable to connect to archive.raspberrypi.org:http: [IP:2a00:1098:80:56::1:1 80]

Attempts at a Solution

My question was marked as spam and wouldn't post so I have not included all ofthe references I found.

Summary: I tried to update /etc/apt/sources.list to a mirror, tried to turn off ipv6, tried to downgrade to older versions of Buster and even Stretch (in combination with using a mirror it almost worked), I have a second (used) Pi Zero W that is having the same issues, and I scoured the internet for solutions.


I found this previous post about upgrade issues and tried some of the North American mirrors (Mainly the university ones that I trust: MTU, Purdue, Berkeley, etc). None of these worked and now I am getting some sort of freeze in my Wi-Fi connection. After the error messages, my internet is hung up on something. Pinging google stops working and I need to reboot the Pi to get it working again. (I tried disabling the power_save feature and it still freezes, so I think the Wi-Fi is hung on a request or something)

The same thread mentions an issue with ipv6, so I tried to disable it with the original source list and the mirrors but nothing is working.


I also tried to downgrade to Raspbian Stretch Lite because of a thread mentioning the issue might be with Buster. This sort of worked, but I had some other issues and unfortunately did not keep track of them since I would rather use the latest release for security and to stay up to date. I tried a couple of other previous versions of Buster and none of them seemed to work.

Each time I try this, I delete all partitions from the SD using Disk Management in Windows and re-format the card. Then I load the new image using Rufus and eject the SD before plugging it in and starting up on the Raspberry Pi. If there is a step I can skip in this process or something I'm doing wrong, please let me know.

Other Pi

Luckily, I also ordered a used Pi Zero W from Ebay and tried all of these methods with the used Pi as well. So, unless these boards have the same defect, I think it is some sort of hardware/OS issue or I am doing something horribly wrong.

EDIT: In all of my frustration, I have been unplugging the Raspberry Pi Zero W without a proper software shutdown. I have a freshly formatted and imaged SD card and will always use shutdown -h now from now on. (apt still did not successfully upgrade)

  • When you ping'd Google what did you get back? Was it an IPv6 or IPv4 address? If it was an IPv6 try sudo apt-get -o Acquire::ForceIPv4=true update then try the full-upgrade as documented raspberrypi.org/documentation/raspbian/updating.md
    – user130616
    Commented Mar 24, 2021 at 14:36
  • Yes, it was IPv6 2607:f8b0:4009:200e. After playing around with it, I need to add -o Acquire::ForceIPv4=true to every apt command I try to use. Without it, the WiFi hangs and I have to reboot the Pi. You can post your suggestion as an answer and I'll accept it. Commented Mar 24, 2021 at 15:53
  • It may be easier to turn IPv6 off overall if other thing mess up like this. Try adding ipv6.disable=1 to the /boot/cmdline.txt and reboot. Make sure the file is one line only and there is one space between this and the last bit of the line. Note first boot changes the file by truncation. It's best to edit this after first boot. Sorry cannot say why it's doing this - removing IPv6 is a kludge not a fix :-)
    – user130616
    Commented Mar 24, 2021 at 17:37
  • Any idea why this might be affecting my ability to stream from the Raspberry Pi? I'm trying to stream the video through VLC and it can't open the MRL (I can post a separate question if not). I'm following this: hackster.io/BnBe_Club/… Commented Mar 24, 2021 at 19:15
  • No idea TBH - it's possible yourWiFi is set to IPv6 only but the LAN is IPv4 - seen it once due to a miss configuration but it's a guess.
    – user130616
    Commented Mar 24, 2021 at 20:38


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.