I'm trying to follow the instructions here in order to install puredata on my Pi. I'm getting the following error:

W: GPG error: http://backports.debian.org squeeze-backports Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 8B48AD6246925553

When I try sudo apt-get update with the repositories in:

  1. http://ftp.uk.debian.org/debian/
  2. http://backports.debian.org/debian-backports

So I tried sudo wget -O - http://backports.org/debian/archive.key | apt-key add - but there is no server at backports.org. So my question is where is the archive.key for these repositories?

3 Answers 3


Try this answer: No PUbKey Error.

I am not sure but I think you only need the generic debian key here. I tried it on my system and it added ok. Let me know if that resolves it for your use.

So, to be clear, and using the OP as source for the key in the following example:

gpg --keyserver pgpkeys.mit.edu --recv-key  8B48AD6246925553      
gpg -a --export 8B48AD6246925553 | sudo apt-key add -
  • 1
    This looks like it was a good answer since it was upvoted and accepted. Can you include the essential parts of the answer from the link here so that link rot can be avoided? I will upvote you when you do.
    – syb0rg
    Dec 13, 2013 at 22:20
  • In the error message that you get - at the end, you should see a code. In the OP, "...because the public key is not available: NO_PUBKEY 8B48AD6246925553" where "8B48AD6246925553" is the key in question. Dec 15, 2013 at 19:41
  • I have updated my answer to reflect the specific soulution based on the key from the OP. Hope that helps! Dec 15, 2013 at 19:47
  • 3
    if pgpkeys.mit.edu doesn't work, try with keyserver.ubuntu.com instead
    – Mladen B.
    Jan 30, 2018 at 14:48
  • 1
    Also of note, you may get two NO_PUBKEY errors -- you'll need to repeat this process for each one.
    – Doktor J
    Aug 14, 2018 at 13:38

In my case a different key ID was missing when I tried to install backports.
The answer above +1 also worked on my raspberry pi3 with raspbian jessie. I'm writing this just to make a point that you can install missing keys with the same method. Bash terminal message was this:

Get:4 http://ftp.debian.org jessie-backports/main armhf Packages [690 kB]
Get:5 http://ftp.debian.org jessie-backports/main Translation-en [488 kB]
Reading package lists... Done
W: There is no public key available for the following key IDs: 7638D0442B90D010

All I had to do is replace the key ID to match the one i was missing, in my case 7638D0442B90D010

gpg --keyserver pgpkeys.mit.edu --recv-key [Insert here your missing key ID]


gpg -a --export [Insert here your missing key ID] | sudo apt-key add -

Now as usual you can properly fetch your raspbian softwares updates with:

sudo apt-get update

  • 1
    that saved my afternoon :-) Apr 29, 2017 at 19:11

Running the command

gpg --keyserver pgpkeys.mit.edu --recv-key  8B48AD6246925553

didn't work for me. gpg baild out with

gpgkeys: key 8B48AD6246925553 can't be retrieved
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

I managed to get it to work using

sudo apt-key adv --recv-key --keyserver keyserver.ubuntu.com 8B48AD6246925553

After that, sudo apt-get update worked fine.

  • 1
    This worked for me, thank you for updating an old question with a more recent workable answer.
    – BishNaboB
    Jan 2, 2018 at 18:09
  • 1
    pgpkeys.mit.edu also didn't work for me, so I tried with keyserver.ubuntu.com and that worked like a charm :) thanks! :)
    – Mladen B.
    Jan 30, 2018 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.