0

Well I ran into a major network failure when I try to get two PIs talking to each other directly through their Ethernet ports. They use to connect to each other and communicate, but for some odd reason one of these PIs wouldn't make the Network connection at all after sometime. For wired it always said NOT CONNECTED. I checked and rechecked all the settings for it like the IP address, netmask, gateway, router, etc... It all checked out just like the other PI. So, I tried to force its network connection by running the following terminal command.

sudo systemctl stop dhcpcd

sudo systemctl start dhcpcd

PI threw up bunch of system errors and one of them was

Failed to get D-Bus connection: Unknown error -1

I did some research online and found out that this is due to a corrupted package Systemd. As I found that systemd is a system and service manager for Linux. It provides aggressive parallelization capabilities, uses socket and D-Bus activation for starting services, offers on-demand starting of daemons, keeps track of processes using Linux control groups, maintains mount and automount points and implements an elaborate transactional dependency-based service control logic.

So, this means I won't be able to connect to the internet either through Ethernet port or WIFI on this PI. Can I download this Systemd package and manually install it on the PI without resorting to completely erasing the SDcard and Installing a fresh copy of PI's OS?

Someone said on their website that all you have to do to fix this issue is install sudo apt-get install systemd-sysv from the repository, but as I said I got NO network or INTERNET connection to or from this PI. What are my options? Any hints or clues will be greatly appreciated.

4
  • "What are my options?" just restore from your backup (like the rest of us would do) – Milliways Apr 2 at 23:39
  • get two PIs talking to each other directly through their Ethernet ports - do these pi's have different static IP addresses on the same subnet? – Jaromanda X Apr 3 at 0:30
  • @JaromandaX Yep. So, instead of spending the whole day debugging and analyzing and wasting my time, I basically did what Milliways suggested even before he posted his comment. Yes, it all works now. My thoughts are that system files dealing with Network connection got corrupted. Both Ethernet and Wifi didn't work. That's why I believe this to be true. – ThN Apr 16 at 17:30
  • got corrupted ... spontaneous corruption like that sounds bad, get a new SD card – Jaromanda X Apr 16 at 23:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.