17

I have a new Raspberry Pi, when I try to type double quotes by using shift and the single quote buttons on the keyboard, I get an @ symbol. When I do shift + 2, I get the double quotes. A few different keys are like this. How do I change this back to normal keyboard orientation?

20

run sudo raspi-config and setup your Locale and Keyboard. These are located under Internationalisation Options

  • 1
    Thanks, this worked well. sudo dpkg-reconfigure keyboard-configuration brought me directly to the keyboard config. – Jordan.J.D Dec 20 '13 at 4:03
  • Didn't work for me. I changed the locale from en_GB.UTF-8 to en_US.UTF-8 and reselected the Dell keyboard, but @ and quote are still swapped. – personal_cloud Aug 10 at 5:21
0

Quote and @ get swapped if you're using a US keyboard with your locale set to UK. To fix: (FIXME why doesn't stackexchange support code in numbered lists?)

ONE. Update raspi-config (I'm not sure if this step is really necessary)

TWO. Enable US locale. raspi-config does not do this (details)

export LANGUAGE=en_US.UTF-8
export LANG=en_US.UTF-8
export LC_ALL=en_US.UTF-8
locale-gen en_US.UTF-8
update-locale en_US.UTF-8

THREE. Go into raspi-config option 4 (Localization Options) -> Change Keyboard Layout

  • select your keyboard
  • If "English (US)" is not shown (probably not -- that was the issue) go find it in Other, and select it. This brings you back to the main keyboard layout menu, where now "English (US)" is available.
  • Finally, select "English (US)" again in the main keyboard layout menu.
  • Select "OK" for the remaining options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.