3

I bought the Official power supply but when I use it in my Pi 3 model B I get a warning saying: "low voltage, please check power supply".

I have checked the voltage on the Pi using a multimeter and it displays 5.2 V, suggesting that it shouldn't be an issue with the power supply.

It has a fresh install of Raspberry Pi OS and the only things connected are a mouse, keyboard and a HDMI output to a monitor.

Are you able to help in any way with diagnosing/fixing the issue with the Pi?

8
  • 1
    Post a photo of this ‘official power supply’.
    – CoderMike
    Apr 8 at 17:45
  • 1
    Anything 'special' about the keyboard / mouse? Some of the modern ones can draw a fair bit of power for backlights etc. Try booting the Pi without one or both devices and see if the warning still shows.
    – user130616
    Apr 8 at 18:17
  • 1
    measure the voltage with the RPi connected and powered on
    – jsotola
    Apr 8 at 18:58
  • The keyboard is Perixx PERIBOARD-409 which has a specified current draw of 100mA
    – Cai
    Apr 8 at 21:05
  • The power supply is this official one which I bought from a Raspberry Pi Approved Reseller. I bought this one because my previous power supply (5 V, 2.5 A) had the same low voltage message coolcomponents.co.uk/products/…
    – Cai
    Apr 8 at 21:07
1

Try getting a shorter / thicker / better quality USB cable to connect the Pi to the PSU. Poor cables can produce all sorts of weird behavior which sometimes only manifest when the current exceeds a certain value or the cable is bent just the right way, while 99% of the time the connection is OK and voltage measurement looks fine.

Also, make sure you measure the voltage on the 5V pin on the GPIO connector, not with some sort of power monitor connected in series with the cable. When the Pi is disconnected, you should measure 0V there, not 5.24V.

1
  • 1
    The official supplies do not use a separate cable.
    – goldilocks
    Apr 9 at 12:33
0

Checking the voltage with a multimeter isn't that useful. If it shows high that is a integrated measurement made at a point of time. It tells you nothing about the voltage which triggered the low voltage warning.

Try the following

  1. a different power supply
  2. a different power cable
  3. a different Pi
2
  • 1
    I have tried two 2.5 A power supplies which have their cable permanently attached I don't have another Pi 3 I can test but I am getting a Pi 4 tomorrow.
    – Cai
    Apr 8 at 21:12
  • Sounds like your Pi3 may be faulty. Have you had anything connected to the GPIO pins that could have damaged it? You realise a Pi4 needs a different power supply?
    – CoderMike
    Apr 9 at 7:14
0

where are you measuring the voltage?

what software is running when the message shows?

How to rule out the peripherals (keybd mouse hdmi):

set up remote-login to the PI (like ssh).

unplug everything, including the keyboard, mouse, and HDMI

boot the pi

connect remotely to pi with ssh (putty on windows)

now run 'dmesg -T' from the command line

 

if there are no low voltage errors in the dmesg log, it means its your mouse, keyboard, or hdmi was causing the problem. 

if there are still low voltage errors in the dmesg log, it means something in your pi or power supply wires/usb jack is not working. 
0

EDIT: Thanks to some help I got in comments, I learned that this is not a good answer for this question. The descriiption in this answer does not describe an anomoly or bug in the undervoltage warning (yellow lightning bolt). Although it's not a helpful answer to this question, it was pointed out that someone who has observed this "discrepancy" might find this "answer".

When you saw the undervoltage lightning bolt, was that on a monitor plugged into the HDMI connector on the RPi, or was it on a VNC connection? I have had both the HDMI into a monitor and VNC over WiFi to a laptop at the same time, but the lightning bolt only appeared on one of them (I think it was on the HDMI). Given the number of power supplies I tried, as well as numerous other such experiences people have posted, and the contradiction between HDMI and VNC, I am inclined to suspect that the problem is with the RPi.

6
  • "VNC over WiFi to a laptop at the same time" -> AFAIK the lighting bolt is a low level graphics hack in the kernel; it's not part of some userland application. It will appear even when no GUI is running. When you use VNC what's being accessed is the user specific Xorg desktop session. Although the lightning bolt appears superimposed on the physical screen, it's not part of that GUI desktop session, so it isn't part of the VNC session either. The warning is usually accompanied by an Under-voltage detected! message in the kernel log (so should show in dmesg and syslog if you use it).
    – goldilocks
    Apr 11 at 21:22
  • " It will appear even when no GUI is running." I guess I don't really understand what a graphical user interface is. Is the GUI what appears on the monitor (the desktop)? Is a terminal window considered a GUI? Or is it the window graphics (frame, buttons) on the desktop part of the GUI but the actual console is just considered text and not graphics? Where does the lightning bolt appear when no GUI is running?
    – TRS-80
    Apr 12 at 5:34
  • You could use GUI to refer to any of the above, I guess. But in this context the point is that VNC is not literally like a video feed of the screen -- that's actually not possible short of a specialized GPU or actually setting a camera up. It is pretty close though in that it is a feed from what the OS "thinks" the screen is (you could use VNC on a headless machine that has no GPU). But the lightning bolt is, if I remember correctly (didn't search for confirmation), implemented in the GPU firmware. Ie., it has no relationship to the OS. And what VNC deals with is the OS, not the GPU.
    – goldilocks
    Apr 12 at 14:20
  • Point being, the OS doesn't display the lightning bolt, there's no application that does it, it is not a feature of the GUI desktop, therefore it won't be part of the VNC feed. It's more or less the equivalent of an LED wired into the hardware that's triggered purely by the hardware.
    – goldilocks
    Apr 12 at 14:22
  • OK, I think I'm getting it now. I think my "answer" isn't to helpful now that I have learned this. I know that deleting a question after an answer has been posted is a no-no. Is there any etiquette about deleting an answer if there are comments to it? If not, I'm giving this one here the axe!
    – TRS-80
    Apr 12 at 21:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.