0

Recently, I brought a new router and it came with its own settings and I didn't bother changing them.

The problem I am facing with my Pi is that its failing to get an address from my router. It keeps requesting the previous adress from the new router which is far greater than the range of ip adresses allowed with the new configuration. This is the log entry in the router after I start the Pi.

aemon.info dnsmasq-dhcp[9816]: DHCPNAK(br0) 192.168.1.143 mac:id address not available

I guess there is some persistance with the dhcp thing in the pi, I am not sure which config file can address that. Are there any better ways than just changing the ip-adress range in the router?

Btw Its a headless setup running arch with a wifi card.

1

It looks like the older settings were persistent as my Pi was running with the file system mounted as read-only.

I changed the mount options for the root file-system and its working now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.