2

I've got a weird problem right now. I updated everything a couple of weeks ago (sudo apt update, upgrade etc.) and after that I had issues with the sound output to my tv via hdmi. I managed to fix it eventually by going to /boot/config.txt and setting hdmi_drive=2, but only for audio from chromium. I still can't get audio from vlc. Weirdly though, if I connect a bluetooth audio output, I can get vlc audio there. In the process of working out the original problem a I downloaded a few things, I think they were related to pulseaudio and bluez(?)

I'm sure there's some setting I just need to adjust but I've no idea where to look, either in vlc or on the pi. Can someone point me in the right direction?

3
+100

Start by checking the PulseAudio settings (pavucontrol) and VLC audio output preferences. First, set everything as on the screenshots and see if that gets HDMI audio going.

If that doesn't help, force VLC audio output to PulseAudio instead of "automatic", play a file with it, and open pavucontrol again. Check the "Configuration" tab (you should see "Digital Stereo Output" selected as the current profile) and "Playback" tab (you should see your VLC there using the default output device. Make sure the settings on all tabs are consistent (VLC is using the output device which is based on "Digital Output" configuration, which in turn mentions HDMI) and nothing is muted along the way.

7
  • Thanks for your help. Forcing the vlc to output module to pulseaudio got the audio to reach HDMI, but bizarrely it only got the background track to the video I was playing by default. I selected the option Audio>Stereo Mode>Mono (it was on Original) and the voice track came in. If I close pavucontrol, the audio stays, but it goes again if I change the Audio>Stereo Mode option. – Phill Apr 19 at 9:41
  • 1
    Actually, on further inspection, forcing the audio to pulseaudio makes no difference. The only thing that gets the audio to work is opening pavucontrol at least once after opening vlc - its a solution, but if I could get it to function automatically that would be better – Phill Apr 19 at 10:08
  • How is PulseAudio started on your system? Via systemd? xdg autostart? On demand via libpulse? On my system it starts via systemd, so I suggest you start by checking if the pulseaudio service is enabled and running. Or just run systemctl --user enable pulseaudio, reboot and check. – Dmitry Grigoryev Apr 19 at 14:03
  • 1
    Ok, so when I check systemctl --user status pulseaudio after a reboot it shows active (running) and --daemonize=no. It looks like it starts in systemd. I still get no audio from vlc until I open pavucontrol. Looking at the list under the status check it shows ...duplicated D-Bus path... for bluez, failed to register audio agent with ofono, and alsa-sink.c: Resume failed - no idea if that has any relevance – Phill Apr 21 at 9:30
  • 1
    Thanks for your help with this! I've given you the bounty because you gave me a working solution, and I'm starting to realise getting it to work automatically is probably worth a separate question. – Phill Apr 23 at 8:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.