1

I'm trying to install Brackets.io on the Pi. But the "create-project" step in Grunt is not very pleased with that try. It tells me that it can't find the gtk+-2.0, nor the gthread-2.0 libraries and that I better check my PKG_CONFIG_PATH environment variables.

When I do a "sudo apt-get install gtk+-2.0" it tells me that it'll use gir1.2-gtk-2.0 instead... so I guess I could change the appshell.gyp file so that it looks for gir instead of gtk+... no problem there... I hope at least.

But when I do a "sudo apt-get install gthread-2.0" it response immediately that it can't find that library... "Unable to locate package gthread-2.0". Any idea's how to fix that ?

4

You need the -dev packages in addition to the normal one if you want to compile against the library.

> apt-cache search gtk+-2.0
[...]
libgtk2.0-dev - development files for the GTK+ library
[...]
> apt-get install libgtk2.0-dev

Gthreads are part of glib, so the dev package should be:

> apt-get install libglib2.0-dev
  • That's it ! Thank you soooooooooo much ! after I installed the libglib2.0-dev and the libgtk2.0-dev the compilation error disappeared. – Michael Bruyninckx Dec 22 '13 at 7:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.