0

I tried plugging my Pi 4 in tonight and I couldn't shell into it. Turns out it never booted so I plugged it back in and noticed that it wasn't showing up on my Ethernet connections list in my router settings. I re-plugged it again and noticed that the red LED wasn't turning on straight away, and it was kind of fading in for a fraction of a second. I tried this a few times with a few different power supplies and each time I try it takes longer to fade in. Now it hangs dim for about 2 seconds or more and flickers a little bit, so I've stopped doing this to avoid damage. There is no activity on the green LED at all.

It seems that there has been some kind of damage to the Pi. The only thing I can think of is that a power line came down nearby last night, though I can't remember if I had it plugged in or not; or that maybe me pulling the power cord in and out irresponsibly has led to some damage. Perhaps there is some way something could have shorted out on the board and I've not noticed it? I have also, in the past, left it running for a very long time on my desk without using it, if that matters at all. Any wisdom on this issue and how it may be fixed is greatly appreciated.

2
  • Are you using the official 5.1V 3.0A power supply? Downed powerline could have damaged psu, Pi or sd card. Try another psu, try another sd card.
    – CoderMike
    Apr 20, 2021 at 11:23
  • I've tried both. Not the official power supply, but ones that have worked before with the same software and the same peripherals (none). And I think that if there was just a supply issue then the symptoms wouldn't be changing as much as they have. E- I'll edit the question to clarify just how much the fade-in time has lengthened.
    – Architect
    Apr 20, 2021 at 11:27

1 Answer 1

1

Just came back to this question a while later, and turns out that when I tested the Pi 2 days later it worked fine. There must be a polyfuse or some stray dirt that was stopping it from turning on. So if this happens to you, don't worry and just wait a while and try again before you panic :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.