0

I'm experimenting with using my Pi as a Wake on LAN Server but only having partial success.

I'm using a RPi 4 and two regular x86-64 desktop PC's. The Pi is running the latest RPi OS Lite and the PC's are running Ubuntu Mate 20.04 an Linux Mint 20.1 respectively. They are all on the same wired network. I have a file, maclist,listing the MAC and IP addresses of the 2 PC's:

1a:2b:3c:4d:5e:6f   192.168.1.101
ff:ee:dd:cc:bb:aa   192.168.1.103

I run the command on the RPi: wakeonlan -f maclist

The machine at 192.168.1.101 starts up fine, however the machine at 192.168.1.103 does not.

I can then ssh from the pi to 192.168.1.101 and issue a wakeonlan command from there and machine 192.168.1.103 wakes up fine. This of course serves as a workaround but it is not my preference. I think it should work - any ideas on what I am doing wrong?

3
  • Not sure it's a pi issue as it wakes one machine. It could be TCP vs UDP wake packets. What happens if you reverse the order in the file? Have you tried two separate wake commands with a pause in between? Have you tried the etherwake program? – user130616 Apr 20 at 18:46
  • 1
    What happens if you change 1a:2b:3c:4d:5e:6f 192.168.1.101 to 1a:2b:3c:4d:5e:6f 255.255.255.255 (universal broadcast address) or 1a:2b:3c:4d:5e:6f 192.168.1.255 (LAN broadcast address). See github.com/jpoliv/wakeonlan#3-how-is-it-implemented-here- – Dougie Apr 20 at 20:48
  • Thanks for your thoughts @Andrew and @Dougie. Changing the IP address to the LAN broadcast address 192.168.1.255 did the trick. In the meantime I've added a 3rd machine to my list - all 3 waking up no problems. Thanks! – robosnacks Apr 21 at 14:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.