-1

I am trying to wget to a server in order to obtain some information. I am running on RPi Zero with the Waveshare Ethernet / USB HUB HAT for Raspberry Pi, 1x RJ45 Ethernet Port, 3x USB Ports

pi@raspberrypi:~ $ uname -a Linux raspberrypi 5.10.17+ #1403 Mon Feb 22 11:26:13 GMT 2021 armv6l GNU/Linux

The command I am trying is

pi@raspberrypi:~ $ wget 82.68.133.179/wifi-drivers/8188eu-drivers/8188eu-5.10.17-v7-1403.tar.gz
--2021-04-20 13:42:07--  http://82.68.133.179/wifi-drivers/8188eu-drivers/8188eu-5.10.17-v7-1403.tar.gz
Connecting to 82.68.133.179:80... failed: No route to host.

when I run apt update, I get the following

pi@raspberrypi:~ $ sudo apt update
Hit:1 http://archive.raspberrypi.org/debian buster InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian buster InRelease                
Err:3 http://packages.microsoft.com/repos/code stable InRelease                
  Could not connect to packages.microsoft.com:80 (104.42.185.173). - connect (113: No route to host)
Reading package lists... Done                             
Building dependency tree       
Reading state information... Done
76 packages can be upgraded. Run 'apt list --upgradable' to see them.
W: Failed to fetch http://packages.microsoft.com/repos/code/dists/stable/InRelease  Could not connect to packages.microsoft.com:80 (104.42.185.173). - connect (113: No route to host)
W: Some index files failed to download. They have been ignored, or old ones used instead.

I can ping the server in question from my Mac

> Marks-iMac:~ markumbach$ ping 169.254.185.110
PING 169.254.185.110 (169.254.185.110): 56 data bytes
64 bytes from 169.254.185.110: icmp_seq=0 ttl=64 time=8.961 ms
64 bytes from 169.254.185.110: icmp_seq=1 ttl=64 time=9.688 ms
64 bytes from 169.254.185.110: icmp_seq=2 ttl=64 time=9.219 ms
64 bytes from 169.254.185.110: icmp_seq=3 ttl=64 time=10.331 ms
64 bytes from 169.254.185.110: icmp_seq=4 ttl=64 time=9.058 ms
64 bytes from 169.254.185.110: icmp_seq=5 ttl=64 time=2.799 ms
64 bytes from 169.254.185.110: icmp_seq=6 ttl=64 time=11.194 ms
64 bytes from 169.254.185.110: icmp_seq=7 ttl=64 time=3.625 ms
64 bytes from 169.254.185.110: icmp_seq=8 ttl=64 time=2.749 ms
64 bytes from 169.254.185.110: icmp_seq=9 ttl=64 time=2.382 ms

but the same ping does not work from the RPi.

> pi@raspberrypi:~ $ ping downloads.fars-robotics.net
PING downloads.fars-robotics.net (82.68.133.179) 56(84) bytes of data.
From raspberrypi.local (169.254.185.110) icmp_seq=1 Destination Host Unreachable
From raspberrypi.local (169.254.185.110) icmp_seq=2 Destination Host Unreachable
From raspberrypi.local (169.254.185.110) icmp_seq=3 Destination Host Unreachable
From raspberrypi.local (169.254.185.110) icmp_seq=4 Destination Host Unreachable
From raspberrypi.local (169.254.185.110) icmp_seq=5 Destination Host Unreachable
From raspberrypi.local (169.254.185.110) icmp_seq=6 Destination Host Unreachable
From raspberrypi.local (169.254.185.110) icmp_seq=7 Destination Host Unreachable
From raspberrypi.local (169.254.185.110) icmp_seq=8 Destination Host Unreachable
From raspberrypi.local (169.254.185.110) icmp_seq=9 Destination Host Unreachable

I tried running

> pi@raspberrypi:~ $ sudo systemctl enable systemd-networkd
Created symlink /etc/systemd/system/dbus-org.freedesktop.network1.service → /lib/systemd/system/systemd-networkd.service.
Created symlink /etc/systemd/system/multi-user.target.wants/systemd-networkd.service → /lib/systemd/system/systemd-networkd.service.
Created symlink /etc/systemd/system/sockets.target.wants/systemd-networkd.socket → /lib/systemd/system/systemd-networkd.socket.
Created symlink /etc/systemd/system/network-online.target.wants/systemd-networkd-wait-online.service → /lib/systemd/system/systemd-networkd-wait-online.service.

to no avail

From this it appears that the router and my internal lan are ok but it looks like any outside communication from my RPi is blocked. I am guessing that it is because I am connecting through the HUB. What do I need to do?

Notes: The RPi Zero is connected using the ethernet connection on the Waveshare Hat via an Ethernet cable to a switch and then to the modem/router. I can ping all of my other computers on the network from the RPi Zero. All other computers on the network can ping the RPi Zero.

I set up a static address on /etc/dhcpcd.conf as follows

interface eth0
static ip_address=192.168.0.227/24
static routers=192.168.0.1
static domain_name_servers=68.105.28.11 8.8.8.8 fd51:42f8:caae:d92e::1
interface wlan0
static ip_address=192.168.0.229/24
static rounters=192.168.0.1
static domain_name_servers=68.105.28.11 8.8.8.8

but the hostname on the RPi zero doesn't when I restart the network.

pi@raspberrypi:~ $ hostname -I
169.254.185.110 2600:8802:3500:f400:48de:ca86:69aa:b0d0 

This must really have something to do with the ethernet port being on the Hat.

My modem/router is my dhcp server

enter image description here

2
  • Could I ask you not to use quote but use the code blocks for output as that's a lot easier to read? Your Pi does not seem to have a valid IP address as 169.254.185.110 is a link-local address and cannot be routed between networks. Your Mac can ping it as it's local to your LAN. You need to get a DHCP or static address on the Pi that matches the rest of your network.
    – user130616
    Apr 20 at 22:55
  • From raspberrypi.local (169.254.185.110) That's a link local address. You have a network problem on your Pi. How exactly is your Pi connected to your LAN? Start with checking the cable and try pinging local devices to check the connection. Add info to your question; do not add it as a comment
    – Dirk
    Apr 21 at 0:24
0

All works correct now. Thanks for the help.

The steps I took to fix it was

  1. run ifconfig
  2. use the ether MAC address under eth0
  3. Manually configure a static on the router/modem.
  4. Restart the RPi. service networking restart did not do it for me.

This site is temporarily in read only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .