1

I'm using the reader below to read mifare cards (13.56mhz), I have an electron/node.js application for this. For some reason after an uncertain amount of time(shortest time I noticed was about 30 minutes) the reader just stops reading, but the power is still on indicated by a red LED on the reader.

I'm using this to do the card reading and also followed the gpio wiring shown. I'm having a hard time figuring out what's wrong since I only experience this on my Pi 3 Model B+(2017), I also have Pi 4's which I don't experience this in. Sometimes restarting the application works and it can read again, sometimes I have to reboot the pi itself. Both are running buster, updated. Same application.

13
  • 1
    add some console.log's to the code where you suspect it may be failing – Jaromanda X Apr 28 at 0:38
  • 1
    @JaromandaX I already tried debugging the section of the javascript code responsible for reading the card, it's not detecting any card at all. – crimson589 Apr 28 at 0:44
  • 1
    so, you can still successfully communicate with the RC522, it just doesn't detect cards? – Jaromanda X Apr 28 at 0:46
  • 1
    does the issue occur after a specific number of reads? – jsotola Apr 28 at 0:49
  • 2
    @JaromandaX browsed a few of them like syslog, user.log, boot, kern. didn't find anything that caught my attention, anything I should be looking for? – crimson589 Apr 28 at 2:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.