1

I have some issues with 5 GHz wifi on my Pi 3B+, it won't discover 5 GHz networks but only 2.4 GHz. I have set the wifi country, try to force the connection with correct SSID / password on the wpa_supplicant.conf file but none of them works.

Here is my wpa_supplicant.conf :

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=FR

network={
        ssid="Bbox-XXXXXXXX"
        psk="XXXXXXXXXXXXXXXXXXXXXXXX"
        key_mgmt=WPA-PSK
}

When I try sudo iw wlan0 scan | grep 'freq:' there is only frequencies like 24XX. Also, I have set a static IP for this device (there is a website hosted). What could be wrong ?

5
  • 1
    What about iw list | grep -P "5\d+ MHz"?
    – goldilocks
    Apr 28, 2021 at 14:03
  • If for the same wpa config file on your WiFi router, your Android phone can detect both 2.4G and 5G, but you Rpi can only detect 2.4G, then there is nothing wrong on your side. The kernel had a (proven) bug years back. Fixed now. See my answer below. I also reported a couple of times in this and other Rpi forums, about my findings with other linux guys..
    – tlfong01
    Apr 28, 2021 at 14:07
  • 1
    @goldilocks♦ It shows * 2452 MHz [9] (20.0 dBm) *2457 MHz [10] (20.0 dBm) @tlfong01 Damn it's bad, I have done a full upgrade but still the same. Indeed I have no problems to connect 5GHz wifi with my other devices (PC, phone, TV and so on). Apr 28, 2021 at 15:19
  • 1
    What about uname -r, just to rule out whatever kernel bug (I think this was actually an issue with firmware and the mainline kernel, so never affected Raspbian anyway).
    – goldilocks
    Apr 28, 2021 at 15:36
  • The result is: 5.10.17-v7+ Apr 29, 2021 at 8:11

1 Answer 1

-1

I had the same problem a couple of years ago. I googled and found it a known/confirmed linux related bug, and all linux experts said it was related to linux kernel and could not fix. So I wait for the linux update. I tried kernel update for one or two years, but the bug was still there. So I gave up and forgot.

Some months ago when I was updating my Rpi4B buster and thought perhaps I could tried again. This time I found no problem detecting both my 2.4GHz and 5GHz WiFi network.

I did not change any setup, still the same simple wpa conf file. It was always the case that my Androd phone can detect 2.4G and 5G, but at the same time for the same wpa config, Rpi could only detect 2.4GHz. (I was using NetGear router, but I think all routers at that time had the same problem.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.