0

Please help as I'm going mad!

im using 2 cameras on the multi cam adapter module on a raspberry pi 4. I followed the Arducam multi cam adapter module documentation. I have been getting this error repeatedly and I do not understand why. any help would be appreciated.

mmal: mmal_vc_component_enable: failed to enable component: ENOSPC

mmal: camera component couldn't be enabled

mmal: main: Failed to create camera component

mmal: Failed to run camera app. Please check for firmware updates

3
  • Most likely you're trying to access the cameras from 2 processes. have you tried searching for that error message?
    – Dirk
    Apr 29 at 8:06
  • yes, now even my single camera does not work even though it is directly connected to my raspberry pi. I have the same error message which I got for my 2 cameras to work. Apr 30 at 5:44
  • Not exactly sure what you're saying,.. To clarify: on a Pi4 you can only access the Pi camera from 1 process. The Arducam device doesn't change that.
    – Dirk
    Apr 30 at 17:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.