1

I am working on a project where I need to connect my RPi 4 to a laptop hotspot. Everything was running OK when I had Ubuntu 18 LTS installed on laptop. After I switched to Ubuntu 20 LTS, RPi 4 won't connect to it.

I tried connecting RPi 4 to other Wifi networks and to hotspot created with Ubuntu 18 and it worked flawlessly. I tried connecting RPi 3B to the same Ubuntu 20 LTS hotspot and it worked to. So only RPi 4 won't connect to hotspot with Ubuntu 20. I am running Raspbian headless and I tried reinstalling it and still doesn't work. Tried switching a Wifi channel hotspot is running on and no luck. Since I have only two RPi 4 I tried with both of them and got same results.

Does anyone have any idea what is happening? Where is best to look for some Wifi log files? Appreciate any help.

UPDATE: Nice to see that thread got some attention. As a currently do not have access to RPi4 I searched for saved logs. This is what I believe was logged on RPi4 when I could not connect to hotspot: enter image description here

7
  • I cannot connect my Pi 4B, with Pi OS (Raspbian buster), to a wireless hotspot on a Ubuntu MATE 20.04 machine. I can connect to my Android device (and my Android device can connect to the Ubuntu 20.04 hotspot). Commented Sep 8, 2021 at 13:16
  • Can you provide the output of the command (from the Pi) iwlist wlan0 scan and if you get any messages in journalctl -r (on the Ubuntu machine) when you switch on the wifi hotspot? Commented Sep 18, 2021 at 3:57
  • Which WiFi channel is your hotspot using? Some channels are not available on the Pi 4. Commented Sep 20, 2021 at 11:14
  • @DmitryGrigoryev - not sure if OP solved the problem; on my setup, I am able to connect only if no authentication is required. Haven't been able to connect with WPA/WPA2. Further details here. Commented Sep 22, 2021 at 7:23
  • I couldn't get my Pi to connect when using 5Ghz channels. Using the old 2.4Ghz Band works fine.
    – PMF
    Commented Sep 22, 2021 at 12:52

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.