I experience a problem with OpenSSH on my Raspberry Pi. SSH service does not start anymore. The following error occurs:

$ sudo systemctl status ssh.service
ssh.service - OpenBSD Secure Shell server Loaded: loaded (lib/systemd/system/ssh.service; enabled; vendor preset: enabled)
Active: failed (Result: signal) since Mon 2021-05-03 07:44:27 CEST; 20s ago Process: 12924 ExecStartPre=/usr/sbin/sshd -t (code=killed, signal=SEGV)
Mai 03 07:44:27 raspberrypi systemd[1]: ssh.service: Service RestartSec=100ms expired, scheduling restart. Mai 03 07:44:27 raspberrypi systemd[1]: ssh.service: Scheduled restart job, restart counter is at 5. 
Mai 03 07:44:27 raspberrypi systemd[1]: Stopped
OpenBSD Secure Shell server. Mai 03 07:44:27 raspberrypi systemd[1]: ssh.service: Start request repeated too quickly. Mai 03 07:44:27 raspberrypi systemd[1]: ssh.service: Failed with result 'signal'. 
Mai 03 07:44:27 raspberrypi systemd[1]: Failed to start OpenBSD Secure Shell server.

When I test my config the following error occurs:

sudo /usr/sbin/sshd -T
Memory access error

I tried to reinstall OpenSSH and created a new config but always the same problem. Does somebody have an idea how I can fix this without reinstalling my whole Pi?

  • Are you running some memory intensive application on this Pi? May 8 '21 at 20:56
  • which model pi? which version of Raspberry Pi OS? did you recently apt upgrade? May 9 '21 at 0:46
  • No only WireGuard is running there. Raspberry Pi 3B, Raspberry Pi OS Lite 2021-01-11 May 9 '21 at 17:01
  • Is your memory OK? Try sudo apt-get update && sudo apt-get install memtester; sudo memtester 500 10 to verify? Can you put OPTIONS="-ddd" in /etc/ssh/sshd_config? May 10 '21 at 7:07
  • There are a number of problems with ssh and Wireguard. Is it possible to stop wireguard? Does sshd start when Wireguard is stopped? May 11 '21 at 13:04

is the message a copy and paste or is it handwritten? Because I see that systemd is still written sysetmd which is weird....the name of the folder is maybe wrongly named?

  • Sorry I could only connect via Console that's why it's handwritten. May 10 '21 at 8:33
  • ok I understand, could you place this order? df -h to see if there is space on the sd
    – user133236
    May 10 '21 at 9:03

After a restart my Pi didn't boot anymore so I tried another micro SD card and reinstalled it. The old card was pretty much broken because. I tried to access it with my Ubuntu notebook but there was nothing readable on it.

Thanks for all your help.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.