0

I am running a Raspberry Pi Zero W as a headless audio player. Since the WiFi-signal in my kitchen is weak, I added an external TL-WN722N v2 WiFi Dongle which greatly improved signal strength.

My problem now is, that i cannot access the raspberry after a few hours of leaving it idle. I already tried numerous things. Power management is turned off permanently, iwconfig says: wlan0: Power Management: off. I am using the 8188eu driver and have also added various parameters that i found online to prevent sleeping. This is how my config looks like:

/etc/modprobe.d/8188eu.conf:
    blacklist r8188eu
    options 8188eu rtw_power_mgnt=0 rtw_enusbss=0 rtw_hwpwrp_detect=0 rtw_low_power=0 rtw_ips_mode=1

I also created the file:

/etc/modprobe.d/usbcore.conf:
    options usbcore autosuspend=-1

I always have to power cycle it, since I obviously also cannot access it via ssh. I'm running Raspbian Buster and also disabled the internal WiFi. The Pi is powered by an external JustBoom Amp Zero.

Is there any more energy saving measures that can be disabled? Or some logs that could be helpful to provide?

Update: According to lsusb the 8188eu driver is actually used:

lsusb
Bus 001 Device 002: ID 2357:010c TP-Link TL-WN722N v2
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
lsusb -t
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Vendor Specific Class, Driver=8188eu, 480M
4
  • IIRC your dongle doesn't use the 8188eu wifi module. You will probably need a different configuration file / modprobe option
    – Dirk
    May 13 at 11:16
  • Mhm, looks like it does (updated question with lsusb output)
    – stainless
    May 13 at 12:49
  • As a USB WifI dongle, I suggest researching whether the problem is power savings at the USB level. May 13 at 19:28
  • @ChadFarmer i already looked into that but apparently the raspi does not do power save for USB. But thats why i have the /etc/modprobe.d/usbcore.conf in there, just in case.
    – stainless
    May 13 at 21:22
0

I resolved the problem by installing another version of the driver. https://github.com/lwfinger/rtl8188eu/issues/371

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.