0

I am trying to PXE boot Ubuntu 20.04 aarch64 on the pi 4b but I am stuck at the point where I need to extract the kernel image vmlinuz-5.4.0-1028-raspi. I tried to zcat and pipe it out but I ended up with an empty file. I have also tried the extract-vmlinuz script but apparently that only works with x86-x64 kernels. Any idea? Thanks

vswitch0:~$ sudo file /var/tftpboot/vmlinuz-5.4.0-1028-raspi
/var/tftpboot/vmlinuz-5.4.0-1028-raspi: gzip compressed data, max compression, from Unix, original size modulo 2^32 23814656
vswitch0:~$ 
3
  • It's gzip compressed, have you not tried using the dd utility with gunzip to get the decompressed image? Or something like 'gzip -dc /var/tftpboot/file | sudo dd of=/dev/rdisk# bs=1m' to flash it to something you can boot from? – cnrcbr May 13 at 22:34
  • zcat should work - exactly how have you executed zcat - perhaps you did it wrong – Jaromanda X May 13 at 23:40
  • gzip -dc /mnt/cdrom/boot/vmlinuz-5.4.0-1028-raspi | dd of=lol did work. Thanks – Pietro May 15 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.