1

I suspect my RPi 3b polyfuse to be blown, but I don't know what's causing it. I'm using an external HDD for booting into DietPi with its own power supply and after every day or so all the USB ports have no power hence RPi doesn't boot (but boots okay with SD card).

Can someone suggest why this happens and how I can prevent this from happening again?
Also, if this keeps happening will the RPi get bricked? Thank you!

A more detailed information about my problem can be found here: No power to usb ports on raspberry pi 3B

1
  • 1
    This is a fair and relevant question, but here's the problem with answering: "The Foundation" - the organization that manufactures and promotes the RPi, and derives economic benefit from its sales - does not publish a full set of useful schematics. Personally, I feel that policy is inconsistent with their stated objectives, but on a practical level your options may be limited to replacement of your RPi, or the "green wire mod" referenced in @goldilocks answer below. – Seamus May 14 at 19:59
3

Can USB ports blow polyfuse on Raspberry Pi 3B?

Not if you mean when backfeeding power from the USB, because the ports are behind the polyfuse (ie., it provides no protection that way). However, that means it does protect against shorts in USB devices (when not backfeeding), although I think the USB current is limited such that maybe a surge of that sort would not happen.

You are not really talking about that either, although the "maybe" there would be the only situation in which a problem with a USB device would trip the fuse. But I don't think the fuse is your problem. The fuse doesn't just kill somethings ("after every day or so all the USB ports have no power"), it cuts power period until the fuse resets.

I have heard that some powered hubs (and so possibly also drives and other devices with their own supply) do potentially backfeed power. This shouldn't be an issue if there is a proper common ground and the voltage is regulated properly, but a misbehaving/broken/defective device might cause problems.

Note that there is no separate polyfuse just for the USB, but someone else has reported your symptoms here:

Raspberry Pi 3 Model B (not B+) USB polyfuse location

Unfortunately the conclusion seems to be that it is because of irreversible damage

4
  • So I came across this question: raspberrypi.stackexchange.com/questions/89239/… and I tried to measure if 5V is being supplied to the USB port or not (P1/P2 to P27) with a multimeter and turns out there is 5V going to USB. So what might be the issue? Are their any other checks I can do to find out what's wrong with my raspberry Pi? I've also tried connecting a USB flash drive and that too is not detected. – Kiran May 17 at 3:14
  • Okay so I measured voltage between PP3-PP27 as suggested here: raspberrypi.org/forums/viewtopic.php?f=28&t=110164 and I found out for me it's fluctuating between 0.01V - 0.06V using the official power supply. I think that's too low? Maybe the power supply is faulty? – Kiran May 21 at 6:22
  • 1
    I guess you could try another supply -- hopefully it is not the pi that is damaged/defective. It sounds like it is to me, unfortunately, but my electronics knowledge is limited and I don't understand all the nitty-gritty details of the board circuitry. – goldilocks May 21 at 15:19
  • Okay. I'll check with another power supply. – Kiran May 21 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.