1

I have a RPi and I'm trying to play a full 1080p HD video @ 60fps. The audio is a few seconds ahead of the video. Is there any way to get the video to maybe drop frames? And I'm using a 256MB model, would a 512 change anything? I am using the following command to launch OMX:

omxplayer -r -o hdmi test.mp4

And here is my config.txt file:

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
disable_overscan=0

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
arm_freq=900

# for more options see http://elinux.org/RPi_config.txt
core_freq=250
sdram_freq=450
over_voltage=2
gpu_mem=128

If you need any more information, just ask (tell me how to get it) and I'll grab it for you. I'm newer to Linux in general.

  • 1
    I've tried this: raspberrypi.stackexchange.com/questions/7716/… – Zachrip Dec 27 '13 at 4:22
  • I have not solved this issue yet :/ – Zachrip Mar 9 '14 at 22:25
  • Done, hopefully someone can help. – Zachrip Mar 15 '14 at 4:13
  • 1
    If you seek within the file does it fix the sync? Does it gradually get more and more out of sync or does it stay constantly out of sync? Does it work OK with 30 FPS video? Do you have the latest version of omxplayer? – Fred Mar 15 '14 at 12:00
  • What memory split are you running? – Steve Robillard Mar 17 '14 at 0:27
0

I am not an expert in media related problems but I think that you should try another media player. After seeing the problem from another point of view I think that it may be the video itself which is creating issues, you can tell me after you play another video otherwise you can try installing vlc media player and follow these steps:- 1. Go to Adjustments and Effects 2. Change the value in the advance of audio over video to a negative number

Credits Ubuntu Forums.

Credits:Ubuntu forums

Some media players for raspbian:- http://raspyplayer.org/raspyplayer-lite.html VLC Media Player Mplayer

Hope this Helps Please tell me if this solved your problem!

  • I'm not sure if Rasbpian ships with a VLC that supports hardware decoding. If you want to try this approach you may need to compile from source: intensecode.blogspot.co.uk/2013/10/… – Fred Mar 19 '14 at 13:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.