-1

I need to use the Raspberry Pi camera with OpenCV. For that, I have to run sudo modprobe bcm2835-v4l. But for that, I need to install it. I did it on another RPi a while ago, but I forgot the whole procedure.

I'm now following a post from here but I got a problem installing libjpeg62-dev :

The following packages have unmet dependencies:
 libjpeg62-dev : Depends: libjpeg62 (= 1:6b2-2)

Then I followed that post and I added deb [trusted=yes] http://mirrordirector.raspbian.org/raspbian/ wheezy main contrib non-free rpi to /etc/apt/sources.list (I should specify [trusted=yes] otherwise the protection prevented me to use that repository). But even after the update, I was not able to install the package (same error).

I also tried to installed libjpeg62 (without dev) myself but it said it will remove 140 (!) packages, which looks important, so I aborted it.

The following packages will be REMOVED:
  adwaita-icon-theme agnostics alacarte arandr chromium-browser chromium-browser-l10n desktop-base dillo ffmpeg fswebcam galculator geany giblib1
  gir1.2-gdkpixbuf-2.0 gir1.2-gtk-3.0 gnome-icon-theme gnome-themes-extra gnome-themes-standard gpicview gstreamer1.0-libav gstreamer1.0-plugins-bad
  gstreamer1.0-plugins-good gtk-update-icon-cache gtk2-engines gtk2-engines-clearlookspix gtk2-engines-pixbuf gtk2-engines-pixflat gvfs-backends
  libavcodec58 libavdevice58 libavfilter7 libavformat58 libcanberra-gtk3-0 libchromaprint1 libcupsfilters1 libdjvulibre21 libfm-gtk4 libfm-modules libgd3
  libgdk-pixbuf2.0-0 libgphoto2-6 libgs9 libgtk-3-0 libgtk2.0-0 libgtk2.0-bin libgtksourceview-3.0-1 libimlib2 libindicator3-7 libjpeg62-turbo
  libkeybinder0 libnotify4 libobrender32v5 libpoppler-qt5-1 libpoppler82 libqt5gui5 libqt5printsupport5 libqt5svg5 libqt5widgets5 libqt5x11extras5
  librsvg2-2 librsvg2-common libsdl-image1.2 libspandsp2 libspectre1 libtiff5 libunique-1.0-0 libv4l-0 libv4lconvert0 libvte-2.91-0 libwebkit2gtk-4.0-37
  libwnck22 libzbar0 lightdm lightdm-gtk-greeter lxappearance lxappearance-obconf lxde lxde-core lxhotkey-gtk lxinput lxpanel lxplug-bluetooth
  lxplug-cputemp lxplug-ejecter lxplug-magnifier lxplug-network lxplug-ptbatt lxplug-volume lxpolkit lxrandr lxsession lxsession-edit lxsession-logout
  lxtask lxterminal mousepad obconf omxplayer openbox openbox-lxde-session pcmanfm pi-greeter pi-package pi-package-data pi-package-session piclone
  pipanel pishutdown piwiz pixflat-icons python-gtk2 python-pil python-pygame python-sense-hat python3-pgzero python3-pil python3-pygame python3-sense-hat
  qpdfview qpdfview-djvu-plugin qpdfview-ps-plugin qpdfview-translations qt5-gtk-platformtheme qt5-style-plugins qt5ct raspberrypi-ui-mods rc-gui
  rp-bookshelf rp-prefapps rpi-chromium-mods scrot sense-hat v4l-utils vlc vlc-plugin-base vlc-plugin-notify vlc-plugin-qt vlc-plugin-skins2 xarchiver
  zenity

Finally, I checked with aptitude, and got that answer:

The following packages have unmet dependencies:
 libjpeg62-turbo : Conflicts: libjpeg62 but 1:6b2-2 is to be installed
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     libjpeg62 [Not Installed]
2)     libjpeg62-dev [Not Installed]

So, it looks like there is a conflict with libjpeg62-turbo, I checked to uninstall it, but again it will remove many packages, hence I aborted it again.

So, now I am a bit lost and I don't know what to do. What should I do to install that package?

Thanks in advance

7
  • are you really using wheezy? May 24, 2021 at 6:25
  • I followed one post that said the package libjpeg62-dev had been removed from the current release and I should use an old one. But I am not familiar with that, so I understood it's not really good, and I planed to remove wheezy when I manage to install my package. May 24, 2021 at 6:30
  • well, following an 8 year old guide is probably not helping - have you tried installing libjpeg62-turbo-dev? May 24, 2021 at 6:38
  • or maybe modprobe bcm2835-v4l2 May 24, 2021 at 6:42
  • having said that bcm2835-v4l2 seems to be loaded at boot anyway May 24, 2021 at 6:47

1 Answer 1

0

As it was proposed in a comment, I installed libjpeg62-turbo-dev, and also I activated the camera in raspi-config and now it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.