1

I flashed the latest retropie image on to my microsd on a raspberry pi 4B using the official raspberry pi imager.

I wanted to do a headless setup since I was on a budget, and it was more appealing to me for retropie to be available to most of my devices over my network, so I followed this guide that promises a headless retropie setup as well as streaming capability in my local network.

https://www.linux-projects.org/uv4l/tutorials/play-retropie-in-browser/

I completed the guide, but when I initialized the browser site, it gave me a dialogue that said “invalid video device”.

Digging deeper, I realized that the technology that powered the streaming is called “uv4l” so I sought out forums that had similar errors; however, the issues other users faced involved a camera peripheral, so their solutions weren’t very applicable to my problem. I’m a novice Raspberry Pi user but I am slightly experienced with Linux and the terminal.

There should be screenshots that contain the webpage that retropie should be running on and the error dialog.

https://share.icloud.com/photos/0B12oPmIkneM35mvmLpHdBbIw

https://share.icloud.com/photos/0xPbmF13cqh_A3_zqbOXKBXyQ

Here is the generated /var/log/syslog

https://pastebin.com/8SLfs0HZ

Are there any solutions to this problem?

1 Answer 1

0

I had this same problem, but found that the service would work if I plugged the pi into an HDMI monitor while it booted. To get around this I found help with the issue on the raspberrypi.org forums: https://www.raspberrypi.org/forums/viewtopic.php?t=253312 Simply edit /boot/config.txt to add (or uncomment) this line:

hdmi_force_hotplug=1

Once I rebooted I could see from the service status (sudo service uv4l_raspidisp status) that the internal error went away and the video would load in my browser, so long as I uncheck "Use h264 hardware acceleration" under "Options".

I then struggled with (and solved) syncing controllers. In case you have problems as well: Steps:

  1. Boot RetroPie (4) when connected to controller and monitor
  2. Plug controller into remote computer
  3. Open your rpi’s IP in Chrome browser
  4. Under ‘Options’: uncheck ‘Use H264 hardware acceleration’
  5. Start stream
  6. ON RetroPie Host: use rpi controller to open up "Main Menu -> Configure Input"
  7. When prompted to 'HOLD A BUTTON' to config, switch to Remote PC controller
  8. Configure your input as you would normally.
  9. Unhook your controller from the rpi
  10. Done!

Hope that helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.