0

To get rid of the soft float vs. hard float ABI problem I tried to install an up-to-date version of mono on my Raspberry Pi with

git clone https://github.com/mono/mono.git
cd mono
git submodule init
git submodule update
./autogen.sh --prefix=/usr/local
make
make install

The make command fails. The errors are as follows:

make[6]: gmcs: Command not found
make[6]: *** [build/deps/basic-profile-check.exe] Error 127
*** The compiler 'gmcs' doesn't appear to be usable.
*** You need Mono version 2.4 or better installed to build MCS
*** Check mono README for information on how to bootstrap a Mono installation.
make[5]: *** [do-profile-check] Error 1
make[4]: *** [profile-do--basic--all] Error 2
make[3]: *** [profiles-do--all] Error 2
make[2]: *** [all-local] Error 2
make[2]: Leaving directory `/home/pi/mono/runtime'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/pi/mono'

To fix this I tried to install mono with "sudo apt-get install mono-runtime" and then start the make again. But the error remains.

Is it possible to get Mono 3.x working on ARM (the Raspberry Pi)?

Update: After installing Mono 2.x with sudo apt-get install mono-complete (before I only installed the runtime) the installation now succeeds. But it still does not work: AFAIK after doing the "make" a "make install" is also required, right? But this fails without any reasons:

*[install-dist_pkdataDATA] Error 1

*[install-am] Error 2

*[install-recursive] Error 1

Feels like I'm getting warmer, but I'm still not there ;-)

  • What do you get when you execute gmcs --version? I was able to compile Mono 3.x on my Pi, but I had the full version of Mono available in the distro installed. – HeatfanJohn Dec 27 '13 at 17:00
  • See update :-) (gcms is version 2.x) – Boris Dec 27 '13 at 18:49
  • Thank you! I finally got it to „make“ and „make install“ without any errors (at least as far as I can see). But when trying „mono —version“ I get „no such file or directory“. Is there one more step to take before mono is fully installed? – Boris Dec 28 '13 at 11:13
  • Do you have /usr/local/bin in your environment's PATH? What happens is you just run /usr/local/bin/mono --version? – HeatfanJohn Dec 28 '13 at 21:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.