1

I am trying to interface MPU-6050 with the Raspberry Pi, Since it require I2C connections so I have connected using the following pins:

3.3V connect to VCC SDA connect to SDA SCL connect to SCL Ground connect to GND

However, when I check if the device is detected using i2cdetect -y 1, nothing is displayed, just the empty I2C address table.

On the other hand, the MPU-6050's yellow light is turned on when it is connected.

I am sure that I have done everything correct because other sensor (BMP085) is being normally displaying in the I2C address table when I try to connect to it, additionally an ADC Pi unit is also normally showing in the I2C table.

I have tried to connect MPU6050 both with and without the BMP085, but in either case, its address is not displaying in the I2C address table.

What could be the problem here?

Beside: VCC, SDA, SCL and GND; am I supposed to connect any other pins too? There are these other pins: XDA, XCL, ADD and INT!

1

Some breakouts need a 5V supply and include a 3.3V regulator for the MPU6050 itself. If that's what you have, then you need5V for Vcc.

You will need to set the ADD to either 0v or 3.3V to chooses between the i2c addresses 0x68 or 0x69.

You can leave XDA, XCL and INT unconnected - XDA / XCL provide a master i2c interface for adding (say) a compass, INT provides an interrupt to let the Rpi know when there is fresh sensor data to be read, but you can just poll for the data instead.

Connecting the ADD to 3.3V through a Resistor, and applying 5Volts to the VCC worked for me. It merits mentioning that you could always check if the device is detected and properly reading the data using these two commands,

i2cdetect -y 1
i2cget -y 1

Replace '1' by '0' if you have an older version of RPi.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.