0

This question probably seems like a duplicate, but I can't find the answer anywhere.

I have a usb flash drive, that I know for a fact is identified by the Pi because I ran lsusb and tail -f /var/log/messages and both Id'd it. But there was one funny thing, the location was sda:

The way I TRIED to mount it was sudo mkdir /mnt/usb and sudo mount /dev/sda /mnt/usb and it succeeded, or at least, it didn't give any errors..

So I tried to cd to it with cd /media/SAMISCOOLCO (SAMISCOOLCO is the name if the usb) and it said no file/directory.. so what do I do!?

I need to be able to use the files from command line.. what do I do?

1

I see a couple of problems with your method:

  1. You are mounting the drive itself, rather than the partition which holds the data on the drive. You would want to mount /dev/sda1 /mnt/usb
  2. You are cd-ing to a different directory to the one you mounted to. If you've mounted it to /mnt/usb, then you need to cd /mnt/usb. However, if you've mounted it at /media/SAMISCOOLCO, you must cd /media/SAMISCOOLCO.

Also, a better method would be to take the USB Drive out, run ls /dev/sd* to see all devices beginning with sd (might be none), then plug the USB in again, run ls /dev/sd* again, and whichever one is new to the list is the one that your drive is. Just make sure you mount /dev/sdXn, not /dev/sdX. (where X is a letter and n is a number).

  • I see what you are saying, let me go re-do it. – Sam Tubb Jan 1 '14 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.