1

I installed Ubuntu 18 (ARM) on a Raspberry Pi 3B so that I could use ROS melodic to control an iRobot Create2. Everything has been going splendidly until I noticed the Google AIY Voice kit I had kicking around on a shelf. Basically, I want to integrate that as well.

However, I can't seem to install the necessary dependencies within Ubuntu to get it up and running. I ran into many headaches with ROS trying to get that running on Raspbian (hence why I dumped it for Ubuntu and an easier apt install, versus compiling from scratch), so I don't want to build backwards from the Raspbian image provided by Google for this.

I'm trying to add the dependencies from the HACKING.md file and have run into this issue:

Package 'raspberrypi-kernel-headers' has no installation candidate when trying to add the button/LED driver and the Voice bonnet driver (aiy-voicebonnet-soundcard-dkms).

I tried installing linux-headers-raspi-hwe-18.04 and linux-headers-raspi2-hwe-18.04, however I still see the same error.

Is this feasible or do I need to try and figure out how to manually interact with it via GPIO or something along those lines?


Edit: here's a direct link to the AIY repo: https://github.com/google/aiyprojects-raspbian/blob/aiyprojects/HACKING.md

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.