I am new to the Pi, loving it.

Just started using HDMI instead of composite pal ( obvious reasons) but I want to keep sound going through AUX so I can play with better speakers. I looked around but very hard to find much information.

Any suggestions would be great, sound was working previously but not any more :( I am running RetroPi, basically Raspbian Model b raspberry pi

3 Answers 3


I think you can use

sudo amixer cset numid=3 <output>

in the terminal with <output> replaced by one of the following numbers for which output you want


1=Audio Jack


  • will give it a shot when I try again tommorow , have found a few other changes I could make to config, hdmi_ignore_edid_audio=1 may work?? browsing through here was good, maybe useful for other beginners elinux.org/RPiconfig thank you will try and inform back tommorow hopefuly
    – Dan r
    Commented Jan 4, 2014 at 23:42

amixer command has no effect for me (Raspberry PI Modell B Rev 2.0, 512MB with Raspbian wheezy).

I have to set hdmi_ignore_edid_audio=1 in /boot/config.txt file and I have to reboot.

Source : http://elinux.org/RPiconfig#Video_mode_options

echo '# Pretends all audio formats are unsupported by display. This means ALSA will default to analogue.' | sudo tee --append /boot/config.txt 
echo 'hdmi_ignore_edid_audio=1' | sudo tee --append /boot/config.txt
sudo shutdown -r now
  1. Start raspi-config from the terminal/CLI:

    sudo raspi-config
  2. select system options

  3. select audio

  4. select '1 headphones'

  5. select "Finish" by pressing the right arrow key twice and pressing enter

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.