I am following the instruction given by How to setup an unprotected Ad Hoc (IBSS) Network and if possible with WPA encryption? but the probelm occurs when I get to the line iw wlan0 set type ibss An error happens: command failed: Device or resource busy I Am using Raspbian buster latest version.

  • Did you exec sudo ifconfig wlan0 down before?
    – Hannes
    Jun 11, 2021 at 22:06
  • Yes, I found the solution. I post it
    – Hans
    Jun 11, 2021 at 22:11

1 Answer 1


The latest raspbian uses wpa_suppplicant, this needs to be disabled in order to change the wlan0 type. Run this command: killall wpa_supplicant

  • Have you also tried just executing sudo ifconfig wlan0 down, then your cmd and then sudo ifconfig wlan0 up. This should also work.
    – Hannes
    Jun 18, 2021 at 5:52
  • Yes, first tried that.
    – Hans
    Jun 19, 2021 at 3:59
  • Another thing to note is that apparently you can't add a virtual interface to pi (I'm using Zero 2) without sharing the channel. If you don't want to share channel you can just make the wlan0 interface itself as IBSS as in the link posted by OP forums.raspberrypi.com/viewtopic.php?f=36&t=138730
    – captain
    Sep 29, 2022 at 18:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.