0

I am using PiFmRds on my raspberry pi 3a+ (https://github.com/ChristopheJacquet/PiFmRds), and I am trying to live broadcast with a mic and a USB sound card. The command is:

sudo arecord -fS16_LE -r 44100 -Dplughw:1,0 -c 2 - | sudo ./pi_fm_rds -audio -

When I run it, though, I get this error: enter image description here

What can I do to get it to work?

1 Answer 1

0

Figured it out! Open terminal and type:

sudo nano /boot/config.txt

Then. go to the line:

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

And replace 'on' with 'off':

# Enable audio (loads snd_bcm2835)
dtparam=audio=off

Then reboot. The only catch is, tho, that your headphone jack won't work anymore. But whateva. Also, if you are having problems with pifm on a newer pi (I had problems on my pi 3), try https://github.com/ChristopheJacquet/PiFmRds

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.